Skip to content
Laskyr

Plugins · v-form · data as of 2026-11-04

Is VPSUForm safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.3.0)

As of 2026-11-04. 7 issues are on record for older versions; version 3.2.25 or newer fixes all of them that state a fix.

Latest version
3.3.0
Last updated
2026-10-27
Active installs
200+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Build contact forms, lead capture forms, and multi-step forms in WordPress — with email automation, conditional logic, and spam protection built in. — by Vikas Ratudi

What to do

  1. Update to the latest version (3.3.0). Anything older than 3.2.25 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get v-form --field=version shows what you run; wp plugin update v-form updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-68551 · published 2025-12-23

Information disclosure in VPSUForm (3.2.24 and older)

Affected
3.2.24 and older
Fixed in
3.2.25
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in Vikas Ratudi VPSUForm v-form allows Retrieve Embedded Sensitive Data.This issue affects VPSUForm: from n/a through <= 3.2.24.

NVD CVE-2025-68551Patchstack advisory

medium 4.3 CVE-2025-58957 · published 2025-09-22

Missing authorization check in VPSUForm (3.2.20 and older)

Affected
3.2.20 and older
Fixed in
3.2.21
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Vikas Ratudi VPSUForm v-form allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects VPSUForm: from n/a through <= 3.2.20.

NVD CVE-2025-58957Patchstack advisory

medium 4.8 CVE-2025-46250 · published 2025-04-22

Stored cross-site scripting (XSS) in VPSUForm (3.1.14 and older)

Affected
3.1.14 and older
Fixed in
3.1.15
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Vikas Ratudi VPSUForm v-form allows Stored XSS.This issue affects VPSUForm: from n/a through <= 3.1.14.

NVD CVE-2025-46250Patchstack advisory

high 7.1 CVE-2025-30778 · published 2025-04-01

Reflected cross-site scripting (XSS) in VPSUForm (3.1.9 and older)

Affected
3.1.9 and older
Fixed in
3.1.10
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Vikas Ratudi VPSUForm v-form allows Reflected XSS.This issue affects VPSUForm: from n/a through <= 3.1.9.

NVD CVE-2025-30778Patchstack advisory

medium 5.4 CVE-2025-24604 · published 2025-01-24

Missing authorization check in VPSUForm (3.0.5 and older)

Affected
3.0.5 and older
Fixed in
3.0.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Vikas Ratudi VPSUForm v-form allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects VPSUForm: from n/a through <= 3.0.5.

NVD CVE-2025-24604Patchstack advisory

high 7.1 CVE-2024-54302 · published 2024-12-13

Reflected cross-site scripting (XSS) in VPSUForm (3.0.0 and older)

Affected
3.0.0 and older
Fixed in
3.0.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Vikas Ratudi VPSUForm v-form allows Reflected XSS.This issue affects VPSUForm: from n/a through <= 3.0.0.

NVD CVE-2024-54302Patchstack advisory

high 7.2 CVE-2024-6770 · published 2024-07-31

Stored cross-site scripting (XSS) in VPSUForm (2.1.5 and older)

Affected
2.1.5 and older
Fixed in
2.1.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Lifetime free Drag & Drop Contact Form Builder for WordPress VForm plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 2.1.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-6770Wordfence advisoryCode change (fix)wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
VPSUForm vulnerability status badge
<a href="https://laskyr.com/plugins/v-form"><img src="https://laskyr.com/plugins/v-form/badge.svg" alt="VPSUForm vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit