Plugins · ux-flat · data as of 2026-11-04
Is UX Flat safe? Known vulnerabilities and latest version
- Latest version
- 5.4.0
- Last updated
- 2025-06-29
- Active installs
- 1,000+
- Known issues on record
- 2
- Unpatched in latest
- 1
- Tested up to WP
- 6.7.11 · PHP 7.4+
Enhance user experience with the sleek and modern design provided by the UX Flat plugin for WordPress websites. — by COP
What to do
- There is no fixed version yet. If you can live without UX Flat for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get ux-flat --field=version shows what you run; wp plugin update ux-flat updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 affects latest 5.4.0 CVE-2026-24576 · published 2026-01-23
Stored cross-site scripting (XSS) in UX Flat (5.4.0 and older)
- Affected
- 5.4.0 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in COP UX Flat ux-flat allows Stored XSS.This issue affects UX Flat: from n/a through <= 5.4.0.
high 7.4 CVE-2024-2459 · published 2024-03-20
Stored cross-site scripting (XSS) in UX Flat (4.4 and older)
- Affected
- 4.4 and older
- Fixed in
- 4.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The UX Flat plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'button' shortcode in all versions up to, and including, 4.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2024-2459Wordfence advisoryCode change (fix)wordpress.org
Recent activity
- 2025-06-29 — latest release on wordpress.org (5.4.0).
- 2026-01-23 — Stored cross-site scripting (XSS) disclosed (CVE-2026-24576), no fix listed yet.
- 2024-03-20 — Stored cross-site scripting (XSS) disclosed (CVE-2024-2459), fixed in 4.6.
Get an email when UX Flat has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for UX Flat (ux-flat) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/ux-flat (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/ux-flat"><img src="https://laskyr.com/plugins/ux-flat/badge.svg" alt="UX Flat vulnerability status"></a>