Plugins · userspn · data as of 2026-11-04
Is Users manager safe? Known vulnerabilities and latest version
- Latest version
- 1.1.70
- Last updated
- 2026-10-12
- Active installs
- fewer than 10
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.2+
Streamline user management on your WordPress site with this powerful plugin. Enable custom forms, secure login, custom login page styling, passkeys (W … — by Félix Martínez
What to do
- Update to the latest version (1.1.70). Anything older than 1.1.20 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get userspn --field=version shows what you run; wp plugin update userspn updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
critical 9.8 CVE-2026-4003 · published 2026-04-08
Privilege escalation in Users manager (1.1.15 and older)
- Affected
- 1.1.15 and older
- Fixed in
- 1.1.20 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Users manager – PN plugin for WordPress is vulnerable to Privilege Escalation via Arbitrary User Meta Update in all versions up to and including 1.1.15. This is due to a flawed authorization logic check in the userspn_ajax_nopriv_server() function within the 'userspn_form_save' case. The conditional only blocks unauthenticated users when the user_id is empty, but when a non-empty user_id is supplied, execution bypasses this check entirely and proceeds to update arbitrary user meta via update_user_meta() without any authentication or authorization verification. Additionally, the nonce required for this AJAX endpoint ('userspn-nonce') is exposed to all visitors via wp_localize_script on the public wp_enqueue_scripts hook, rendering the nonce check ineffective as a security control. This makes it possible for unauthenticated attackers to update arbitrary user metadata for any user account, including the userspn_secret_token field.
NVD CVE-2026-4003Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-12 — latest release on wordpress.org (1.1.70).
- 2026-04-08 — Privilege escalation disclosed (CVE-2026-4003), fixed in 1.1.20.
Get an email when Users manager has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Users manager (userspn) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Privilege escalation (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/userspn (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/userspn"><img src="https://laskyr.com/plugins/userspn/badge.svg" alt="Users manager vulnerability status"></a>