Skip to content
Laskyr

Plugins · userfeedback-lite · data as of 2026-11-04

Is UserFeedback safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.12.0)

As of 2026-11-04. 9 issues are on record for older versions; version 1.11.0 or newer fixes all of them that state a fix.

Latest version
1.12.0
Last updated
2026-09-16
Active installs
200,000+
Known issues on record
9
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Ultimate user feedback plugin to ask questions, surveys, polls, from your website in seconds — by Syed Balkhi

What to do

  1. Update to the latest version (1.12.0). Anything older than 1.11.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get userfeedback-lite --field=version shows what you run; wp plugin update userfeedback-lite updates it.

Check your version

Known vulnerabilities

9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.6 CVE-2026-39475 · published 2026-04-08

SQL injection in UserFeedback (1.10.1 and older)

Affected
1.10.1 and older
Fixed in
1.11.0
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Syed Balkhi User Feedback userfeedback-lite allows Blind SQL Injection.This issue affects User Feedback: from n/a through <= 1.10.1.

NVD CVE-2026-39475Patchstack advisory

medium 4.3 CVE-2026-39476 · published 2026-04-08

Missing authorization check in UserFeedback (1.10.1 and older)

Affected
1.10.1 and older
Fixed in
1.11.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Syed Balkhi User Feedback userfeedback-lite allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects User Feedback: from n/a through <= 1.10.1.

NVD CVE-2026-39476Patchstack advisory

high 7.6 CVE-2025-68496 · published 2025-12-24

SQL injection in UserFeedback (1.10.0 and older)

Affected
1.10.0 and older
Fixed in
1.10.1
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Syed Balkhi User Feedback userfeedback-lite allows Blind SQL Injection.This issue affects User Feedback: from n/a through <= 1.10.0.

NVD CVE-2025-68496Patchstack advisory

medium 5.3 CVE-2025-10694 · published 2025-10-25

Missing authorization check in UserFeedback (1.8.0 and older)

Affected
1.8.0 and older
Fixed in
1.9.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The User Feedback – Create Interactive Feedback Form, User Surveys, and Polls in Seconds plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the `maybe_load_onboarding_wizard` function in all versions up to, and including, 1.8.0. This makes it possible for unauthenticated attackers to access the onboarding wizard page and view configuration information including the administrator email address.

NVD CVE-2025-10694Wordfence advisoryCode change (fix)

medium 5.3 CVE-2023-50887 · published 2024-12-09

Missing authorization check in UserFeedback (1.0.10 and older)

Affected
1.0.10 and older
Fixed in
1.0.11
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Syed Balkhi User Feedback userfeedback-lite allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects User Feedback: from n/a through <= 1.0.10.

NVD CVE-2023-50887Patchstack advisory

medium 6.1 CVE-2024-5902 · published 2024-07-12

Stored cross-site scripting (XSS) in UserFeedback (1.0.15 and older)

Affected
1.0.15 and older
Fixed in
1.0.16 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The User Feedback – Create Interactive Feedback Form, User Surveys, and Polls in Seconds plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the name parameter in all versions up to, and including, 1.0.15 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in feedback form responses that will execute whenever a high-privileged user tries to view them.

NVD CVE-2024-5902Wordfence advisoryPlugin source

medium 6.1 CVE-2024-0903 · published 2024-02-22

Stored cross-site scripting (XSS) in UserFeedback (1.0.13 and older)

Affected
1.0.13 and older
Fixed in
1.0.14 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The User Feedback – Create Interactive Feedback Form, User Surveys, and Polls in Seconds plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'page_submitted' 'link' value in all versions up to, and including, 1.0.13 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in the feedback submission page that will execute when a user clicks the link, while also pressing the command key.

NVD CVE-2024-0903Wordfence advisoryCode change (fix)

medium 6.1 CVE-2023-46153 · published 2023-10-27

Stored cross-site scripting (XSS) in UserFeedback (1.0.9 and older)

Affected
1.0.9 and older
Fixed in
1.0.10
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Stored Cross-Site Scripting (XSS) vulnerability in UserFeedback Team User Feedback plugin <= 1.0.9 versions.

NVD CVE-2023-46153Patchstack advisory

medium 6.1 CVE-2023-39308 · published 2023-09-29

Stored cross-site scripting (XSS) in UserFeedback (1.0.7 and older)

Affected
1.0.7 and older
Fixed in
1.0.8
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Stored Cross-Site Scripting (XSS) vulnerability in UserFeedback Team User Feedback plugin <= 1.0.7 versions.

NVD CVE-2023-39308Patchstack advisoryrevan-ar.medium.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
UserFeedback vulnerability status badge
<a href="https://laskyr.com/plugins/userfeedback-lite"><img src="https://laskyr.com/plugins/userfeedback-lite/badge.svg" alt="UserFeedback vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit