Plugins · user-verification · data as of 2026-11-04
Is User Verification by PickPlugins safe? Known vulnerabilities and latest version
- Status
- Closed 2026-08-06
- Known issues on record
- 4
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate user-verification && wp plugin delete user-verification
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 4 record(s) do not state which versions are affected.
high 7.5 CVE-2026-14861 · published 2026-08-19
Missing authorization check in User Verification by PickPlugins (2.0.47 and older)
- Affected
- 2.0.47 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The User Verification by PickPlugins WordPress plugin through 2.0.47 does not verify that a request to resend a verification email is authorized to act on the supplied user, nor bind the protecting token to that user, allowing unauthenticated attackers to reset arbitrary users' email-verification status and lock them, including administrators, out of their accounts.
critical 9.8 CVE-2026-7458 · published 2026-05-02
Authentication bypass in User Verification by PickPlugins (2.0.46 and older)
- Affected
- 2.0.46 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The User Verification by PickPlugins plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 2.0.46. This is due to the use of a loose PHP comparison operator to validate OTP codes in the "user_verification_form_wrap_process_otpLogin" function. This makes it possible for unauthenticated attackers to log in as any user with a verified email address, such as an administrator, by submitting a "true" OTP value.
NVD CVE-2026-7458Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2026-32497 · published 2026-03-25
Security issue in User Verification by PickPlugins (2.0.45 and older)
- Affected
- 2.0.45 and older
- Fixed in
- 2.0.46
- Access needed (per CVSS)
- No login needed
- Range from
- advisory text · score by Patchstack
Details from the advisory
Weak Authentication vulnerability in PickPlugins User Verification user-verification allows Authentication Abuse.This issue affects User Verification: from n/a through <= 2.0.45.
critical 9.8 CVE-2025-12374 · published 2025-12-05
Authentication bypass in User Verification by PickPlugins (2.0.44 and older)
- Affected
- 2.0.44 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Email Verification, Email OTP, Block Spam Email, Passwordless login, Hide Login, Magic Login – User Verification plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 2.0.44. This is due to the plugin not properly validating that an OTP was generated before comparing it to user input in the "user_verification_form_wrap_process_otpLogin" function. This makes it possible for unauthenticated attackers to log in as any user with a verified email address, such as an administrator, by submitting an empty OTP value.
NVD CVE-2025-12374Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-08-06 — closed on wordpress.org (Security Issue).
- 2026-08-19 — Missing authorization check disclosed (CVE-2026-14861), fix version not stated.
- 2026-05-02 — Authentication bypass disclosed (CVE-2026-7458), fix version not stated.
- 2026-03-25 — Security issue disclosed (CVE-2026-32497), fixed in 2.0.46.
Get an email when User Verification by PickPlugins has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for User Verification by PickPlugins (user-verification) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Authentication bypass (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/user-verification (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/user-verification"><img src="https://laskyr.com/plugins/user-verification/badge.svg" alt="User Verification by PickPlugins vulnerability status"></a>