Plugins · user-role-editor · data as of 2026-11-01
Is User Role Editor safe? Known vulnerabilities and latest version
- Latest version
- 4.66.3
- Last updated
- 2026-10-26
- Active installs
- 700,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.2 · PHP 8.2+
User Role Editor WordPress plugin makes user roles and capabilities changing easy. Edit/add/delete WordPress user roles and capabilities. — by Vladimir Garagulya
What to do
- Update to the latest version (4.66.3). Anything older than 4.64.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get user-role-editor --field=version shows what you run; wp plugin update user-role-editor updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.8 CVE-2024-12293 · published 2024-12-17
Cross-site request forgery (CSRF) in User Role Editor (4.64.3 and older)
- Affected
- 4.64.3 and older
- Fixed in
- 4.64.4 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The User Role Editor plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.64.3. This is due to missing or incorrect nonce validation on the update_roles() function. This makes it possible for unauthenticated attackers to add or remove roles for arbitrary users, including escalating their privileges to administrator, via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2024-12293Wordfence advisoryCode change (fix)wordpress.orgPlugin source
Recent activity
- 2026-10-26 — latest release on wordpress.org (4.66.3).
- 2024-12-17 — Cross-site request forgery (CSRF) disclosed (CVE-2024-12293), fixed in 4.64.4.
Get an email when User Role Editor has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for User Role Editor (user-role-editor) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/user-role-editor (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/user-role-editor"><img src="https://laskyr.com/plugins/user-role-editor/badge.svg" alt="User Role Editor vulnerability status"></a>