Skip to content
Laskyr

Plugins · user-management · data as of 2026-11-04

Is User Management safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4)

As of 2026-11-04. 3 issues are on record for older versions; version 1.4 or newer fixes all of them that state a fix.

Latest version
1.4
Last updated
2026-10-23
Active installs
60+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

User Import Export plugin allows you to export and import WordPress Users and Roles. — by Saad Iqbal

What to do

  1. Update to the latest version (1.4). Anything older than 1.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get user-management --field=version shows what you run; wp plugin update user-management updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-12097 · published 2026-07-08

Missing authorization check in User Management (1.2 and older)

Affected
1.2 and older
Fixed in
1.4 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The User Management plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 1.2. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for unauthenticated attackers to modify the plugin's export field configuration stored in the uiewp_export_field option, controlling which user fields such as password hashes are included in CSV exports and how columns are mapped during imports.

NVD CVE-2026-12097Wordfence advisoryPlugin source

high 8.8 CVE-2025-22736 · published 2025-01-15

Privilege escalation in User Management (1.2 and older)

Affected
1.2 and older
Fixed in
1.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Incorrect Privilege Assignment vulnerability in Saad Iqbal User Management user-management allows Privilege Escalation.This issue affects User Management: from n/a through <= 1.2.

NVD CVE-2025-22736Patchstack advisory

critical 9.9 CVE-2024-52403 · published 2024-11-16

Arbitrary file upload in User Management (1.1 and older)

Affected
1.1 and older
Fixed in
1.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unrestricted Upload of File with Dangerous Type vulnerability in Saad Iqbal User Management user-management allows Upload a Web Shell to a Web Server.This issue affects User Management: from n/a through <= 1.1.

NVD CVE-2024-52403Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
User Management vulnerability status badge
<a href="https://laskyr.com/plugins/user-management"><img src="https://laskyr.com/plugins/user-management/badge.svg" alt="User Management vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit