Skip to content
Laskyr

Plugins · user-login-history · data as of 2026-11-04

Is User Login History safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1.8)

As of 2026-11-04. 2 issues are on record for older versions; version 2.1.8 or newer fixes all of them that state a fix.

Latest version
2.1.8
Last updated
2026-03-17
Active installs
10,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.4+

Helps you to know your website's visitors by tracking their login related information like login/logout time, country, browser and many more. — by Faiyaz Alam

What to do

  1. Update to the latest version (2.1.8). Anything older than 2.1.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get user-login-history --field=version shows what you run; wp plugin update user-login-history updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.9 CVE-2026-2283 · published 2026-08-16

SQL injection in User Login History (2.1.7 and older)

Affected
2.1.7 and older
Fixed in
2.1.8 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The User Login History plugin for WordPress is vulnerable to SQL Injection via the 'blog_id' parameter in all versions up to, and including, 2.1.7. This is due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. This is only exploitable on multisite installations.

NVD CVE-2026-2283Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-47676 · published 2025-05-07

Stored cross-site scripting (XSS) in User Login History (2.1.6 and older)

Affected
2.1.6 and older
Fixed in
2.1.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Faiyaz Alam User Login History user-login-history allows Stored XSS.This issue affects User Login History: from n/a through <= 2.1.6.

NVD CVE-2025-47676Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
User Login History vulnerability status badge
<a href="https://laskyr.com/plugins/user-login-history"><img src="https://laskyr.com/plugins/user-login-history/badge.svg" alt="User Login History vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit