Plugins · user-admin-simplifier · data as of 2026-11-04
Is User Admin Simplifier safe? Known vulnerabilities and latest version
- Latest version
- 3.1.1
- Last updated
- 2026-08-19
- Active installs
- 10,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Lets any Administrator simplify the WordPress Admin interface, on a per-user basis, by turning specific menu/submenu sections off. — by Adam Silverstein
What to do
- Update to the latest version (3.1.1). Anything older than 3.0.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get user-admin-simplifier --field=version shows what you run; wp plugin update user-admin-simplifier updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-11775 · published 2026-06-19
Cross-site request forgery (CSRF) in User Admin Simplifier (3.0.0 and older)
- Affected
- 3.0.0 and older
- Fixed in
- 3.0.1 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The User Admin Simplifier plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.0.0. This is due to missing or incorrect nonce validation on the useradminsimplifier_options_page function. This makes it possible for unauthenticated attackers to reset and permanently delete any user's stored menu and admin-bar configuration via a forged request that triggers uas_save_admin_options() and overwrites the useradminsimplifier_options database entry via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2026-11775Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-08-19 — latest release on wordpress.org (3.1.1).
- 2026-06-19 — Cross-site request forgery (CSRF) disclosed (CVE-2026-11775), fixed in 3.0.1.
Get an email when User Admin Simplifier has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for User Admin Simplifier (user-admin-simplifier) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/user-admin-simplifier (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/user-admin-simplifier"><img src="https://laskyr.com/plugins/user-admin-simplifier/badge.svg" alt="User Admin Simplifier vulnerability status"></a>