Plugins · user-access-manager · data as of 2026-11-04
Is User Access Manager safe? Known vulnerabilities and latest version
- Latest version
- 2.3.20
- Last updated
- 2026-09-10
- Active installs
- 10,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.0+
With the "User Access Manager"-plugin you can manage the access to your posts, pages and files. — by gm_alex
What to do
- Update to the latest version (2.3.20). Anything older than 2.3.19 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get user-access-manager --field=version shows what you run; wp plugin update user-access-manager updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.1 CVE-2026-19797 · published 2026-09-09
Reflected cross-site scripting (XSS) in User Access Manager (2.3.18 and older)
- Affected
- 2.3.18 and older
- Fixed in
- 2.3.19 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The User Access Manager plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'tab_group_section' parameter in all versions up to, and including, 2.3.18 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2026-19797Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2026-18035 · published 2026-08-12
Missing authorization check in User Access Manager (older than 2.3.15)
- Affected
- older than 2.3.15
- Fixed in
- 2.3.15
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The User Access Manager WordPress plugin before 2.3.15 does not apply its access restrictions to REST API requests, allowing unauthenticated attackers to read the content of posts, pages and custom post types that have been restricted to specific user groups.
medium 6.5 CVE-2026-15281 · published 2026-08-05
SQL injection in User Access Manager (2.3.12 and older)
- Affected
- 2.3.12 and older
- Fixed in
- 2.3.13 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The User Access Manager plugin for WordPress is vulnerable to Second-Order SQL Injection via the 'id' parameter of the wp_ajax_save-attachment-compat AJAX action in versions up to, and including, 2.3.12. This is due to insufficient validation on the objectId value stored in the saveAjaxAttachmentData() function and subsequent unparameterized concatenation in the addQueryExcludedPostFilter() function — the stored value is later retrieved from the database and used as an array key, then directly imploded into a SQL NOT IN() clause without integer casting or prepared statements. This makes it possible for authenticated attackers, with subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
NVD CVE-2026-15281Wordfence advisoryCode change (fix)Plugin source
high 7.5 CVE-2026-18352 · published 2026-08-02
Path traversal / file read in User Access Manager (2.3.15 and older)
- Affected
- 2.3.15 and older
- Fixed in
- 2.3.16 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The User Access Manager plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 2.3.15 via the 'uamgetfile' parameter parameter. This makes it possible for unauthenticated attackers to read the contents of arbitrary files on the server, which can contain sensitive information. This is possible because when attachment_url_to_postid() returns 0 for a traversal path, the plugin falls back to the global post set by a valid ?attachment_id parameter supplied by the attacker, causing the access check to pass against a legitimate public attachment while the file streamed is the attacker-chosen path.
NVD CVE-2026-18352Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2022-1601 · published 2023-08-30
Security issue in User Access Manager (older than 2.2.18)
- Affected
- older than 2.2.18
- Fixed in
- 2.2.18
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The User Access Manager WordPress plugin before 2.2.18 prioritizes getting a visitor's IP from certain HTTP headers over PHP's REMOTE_ADDR, which makes it possible for attackers to access restricted content in certain situations.
high 8.8 CVE-2011-5328 · published 2019-08-20
Cross-site request forgery (CSRF) in User Access Manager (older than 1.2)
- Affected
- older than 1.2
- Fixed in
- 1.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The user-access-manager plugin before 1.2 for WordPress has CSRF.
Recent activity
- 2026-09-10 — latest release on wordpress.org (2.3.20).
- 2026-09-09 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-19797), fixed in 2.3.19.
- 2026-08-12 — Missing authorization check disclosed (CVE-2026-18035), fixed in 2.3.15.
- 2026-08-05 — SQL injection disclosed (CVE-2026-15281), fixed in 2.3.13.
Get an email when User Access Manager has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for User Access Manager (user-access-manager) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1) · Missing authorization (1) · SQL injection (1) · Path traversal and file read (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/user-access-manager (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/user-access-manager"><img src="https://laskyr.com/plugins/user-access-manager/badge.svg" alt="User Access Manager vulnerability status"></a>