Plugins · url-image-importer · data as of 2026-11-04
Is URL Image Importer safe? Known vulnerabilities and latest version
- Latest version
- 1.2.4
- Last updated
- 2026-09-29
- Active installs
- 1,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
Import external images into your WordPress Media Library from any URL, CSV, XML export, or Google Drive link. Bulk import, site migration ready. — by Infinite Uploads
What to do
- Update to the latest version (1.2.4). Anything older than 1.0.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get url-image-importer --field=version shows what you run; wp plugin update url-image-importer updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2025-14120 · published 2026-01-06
Stored cross-site scripting (XSS) in URL Image Importer (1.0.7 and older)
- Affected
- 1.0.7 and older
- Fixed in
- 1.0.8 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The URL Image Importer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 1.0.7 due to insufficient sanitization of SVG files. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
NVD CVE-2025-14120Wordfence advisoryCode change (fix)Plugin source
high 8.8 CVE-2025-12138 · published 2025-11-21
Arbitrary file upload in URL Image Importer (1.0 to 1.0.6)
- Affected
- 1.0 to 1.0.6
- Fixed in
- 1.0.7 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The URL Image Importer plugin for WordPress is vulnerable to arbitrary file uploads due to insufficient file type validation in all versions up to, and including, 1.0.6. This is due to the plugin relying on a user-controlled Content-Type HTTP header to validate file uploads in the 'uimptr_import_image_from_url()' function which writes the file to the server before performing proper validation. This makes it possible for authenticated attackers, with Author-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible via the uploaded PHP file.
NVD CVE-2025-12138Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-09-29 — latest release on wordpress.org (1.2.4).
- 2026-01-06 — Stored cross-site scripting (XSS) disclosed (CVE-2025-14120), fixed in 1.0.8.
- 2025-11-21 — Arbitrary file upload disclosed (CVE-2025-12138), fixed in 1.0.7.
Get an email when URL Image Importer has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for URL Image Importer (url-image-importer) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Infinite Uploads (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1) · Arbitrary file upload (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/url-image-importer (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/url-image-importer"><img src="https://laskyr.com/plugins/url-image-importer/badge.svg" alt="URL Image Importer vulnerability status"></a>