Skip to content
Laskyr

Plugins · upsell-order-bump-offer-for-woocommerce · data as of 2026-11-04

Is Upsell Funnel Builder for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.7)

As of 2026-11-04. 5 issues are on record for older versions; version 3.1.7 or newer fixes all of them that state a fix.

Latest version
3.1.7
Last updated
2026-10-30
Active installs
2,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Upsell Funnel Builder lets you create WooCommerce Upsells, Order Bumps, One Click upsell, Cross-Sells, Frequently Bought, and Popups. — by WP Swings

What to do

  1. Update to the latest version (3.1.7). Anything older than 3.1.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get upsell-order-bump-offer-for-woocommerce --field=version shows what you run; wp plugin update upsell-order-bump-offer-for-woocommerce updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-116409 · published 2026-10-29

Reflected cross-site scripting (XSS) in Upsell Funnel Builder for WooCommerce (3.1.6 and older)

Affected
3.1.6 and older
Fixed in
3.1.7 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Swings Upsell Order Bump Offer for WooCommerce upsell-order-bump-offer-for-woocommerce allows Reflected XSS.This issue affects Upsell Order Bump Offer for WooCommerce: from n/a through 3.1.6.

NVD CVE-2026-116409Patchstack advisory

high 7.1 CVE-2026-81288 · published 2026-09-02

Cross-site scripting (XSS) in Upsell Funnel Builder for WooCommerce (3.1.5 and older)

Affected
3.1.5 and older
Fixed in
3.1.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Upsell Order Bump Offer for WooCommerce <= 3.1.5 versions.

NVD CVE-2026-81288Patchstack advisory

high 7.5 CVE-2026-49110 · published 2026-06-15

Security issue in Upsell Funnel Builder for WooCommerce (3.1.4 and older)

Affected
3.1.4 and older
Fixed in
3.1.5
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Authentication in Upsell Order Bump Offer for WooCommerce <= 3.1.4 versions.

NVD CVE-2026-49110Patchstack advisory

medium 6.5 CVE-2025-59565 · published 2025-09-22

Stored cross-site scripting (XSS) in Upsell Funnel Builder for WooCommerce (3.0.7 and older)

Affected
3.0.7 and older
Fixed in
3.0.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Swings Upsell Order Bump Offer for WooCommerce upsell-order-bump-offer-for-woocommerce allows Stored XSS.This issue affects Upsell Order Bump Offer for WooCommerce: from n/a through <= 3.0.7.

NVD CVE-2025-59565Patchstack advisory

medium 5.3 CVE-2025-3743 · published 2025-04-25

Security issue in Upsell Funnel Builder for WooCommerce (3.0.0 and older)

Affected
3.0.0 and older
Fixed in
3.0.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Upsell Funnel Builder for WooCommerce plugin for WordPress is vulnerable to order manipulation in all versions up to, and including, 3.0.0. This is due to the plugin allowing the additional product ID and discount field to be manipulated prior to processing via the 'add_offer_in_cart' function. This makes it possible for unauthenticated attackers to arbitrarily update the product associated with any order bump, and arbitrarily update the discount applied to any order bump item, when adding it to the cart.

NVD CVE-2025-3743Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Upsell Funnel Builder for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/upsell-order-bump-offer-for-woocommerce"><img src="https://laskyr.com/plugins/upsell-order-bump-offer-for-woocommerce/badge.svg" alt="Upsell Funnel Builder for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit