Plugins · upmenu · data as of 2026-11-04
Is UpMenu safe? Known vulnerabilities and latest version
- Latest version
- 3.2
- Last updated
- 2026-05-21
- Active installs
- 30+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8
This plugin allows you to easily integrate UpMenu with your Wordpress website. — by upmenu
What to do
- Update to the latest version (3.2). Anything older than 3.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get upmenu --field=version shows what you run; wp plugin update upmenu updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-1910 · published 2026-02-14
Stored cross-site scripting (XSS) in UpMenu (3.1 and older)
- Affected
- 3.1 and older
- Fixed in
- 3.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The UpMenu – Online ordering for restaurants plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'lang' attribute of the 'upmenu-menu' shortcode in all versions up to, and including, 3.1. This is due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recent activity
- 2026-05-21 — latest release on wordpress.org (3.2).
- 2026-02-14 — Stored cross-site scripting (XSS) disclosed (CVE-2026-1910), fixed in 3.2.
Get an email when UpMenu has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for UpMenu (upmenu) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/upmenu (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/upmenu"><img src="https://laskyr.com/plugins/upmenu/badge.svg" alt="UpMenu vulnerability status"></a>