Skip to content
Laskyr

Plugins · upi-qr-code-payment-for-woocommerce · data as of 2026-11-04

Is UPI QR Code Payment Gateway for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.7.0)

As of 2026-11-04. 3 issues are on record for older versions; version 1.7.0 or newer fixes all of them that state a fix.

Latest version
1.7.0
Last updated
2026-10-21
Active installs
10,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.2 · PHP 7.0+

This Plugin enables WooCommerce shop owners to get direct and instant payments through UPI apps like BHIM, GooglePay, PhonePe or any banking UPI app. — by KnitPay

What to do

  1. Update to the latest version (1.7.0). Anything older than 1.7.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get upi-qr-code-payment-for-woocommerce --field=version shows what you run; wp plugin update upi-qr-code-payment-for-woocommerce updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-114191 · published 2026-10-24

Missing authorization check in UPI QR Code Payment Gateway for WooCommerce (1.6.3 and older)

Affected
1.6.3 and older
Fixed in
1.7.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Knit Pay UPI QR Code Payment Gateway for WooCommerce upi-qr-code-payment-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects UPI QR Code Payment Gateway for WooCommerce: from n/a through 1.6.3.

NVD CVE-2026-114191Patchstack advisory

medium 5.4 CVE-2026-56023 · published 2026-06-25

Missing authorization check in UPI QR Code Payment Gateway for WooCommerce (1.6.2 and older)

Affected
1.6.2 and older
Fixed in
1.6.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Customer Broken Access Control in UPI QR Code Payment Gateway for WooCommerce <= 1.6.2 versions.

NVD CVE-2026-56023Patchstack advisory

medium 6.5 CVE-2025-67969 · published 2026-02-20

Missing authorization check in UPI QR Code Payment Gateway for WooCommerce (1.5.1 and older)

Affected
1.5.1 and older
Fixed in
1.6.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in knitpay UPI QR Code Payment Gateway for WooCommerce upi-qr-code-payment-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects UPI QR Code Payment Gateway for WooCommerce: from n/a through <= 1.5.1.

NVD CVE-2025-67969Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
UPI QR Code Payment Gateway for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/upi-qr-code-payment-for-woocommerce"><img src="https://laskyr.com/plugins/upi-qr-code-payment-for-woocommerce/badge.svg" alt="UPI QR Code Payment Gateway for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit