Plugins · upcoming-for-calendly · data as of 2026-11-04
Is Upcoming for Calendly safe? Known vulnerabilities and latest version
- Latest version
- 2.0.2
- Last updated
- 2026-07-10
- Active installs
- 100+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 8.0+
Display a list of upcoming already-scheduled Calendly events that still have open slots, and link to their specific registration pages. — by justdave
What to do
- Update to the latest version (2.0.2). Anything older than 1.2.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get upcoming-for-calendly --field=version shows what you run; wp plugin update upcoming-for-calendly updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2025-14160 · published 2025-12-12
Cross-site request forgery (CSRF) in Upcoming for Calendly (1.2.4 and older)
- Affected
- 1.2.4 and older
- Fixed in
- 1.2.5 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Upcoming for Calendly plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.2.4. This is due to missing nonce validation on the settings update functionality. This makes it possible for unauthenticated attackers to update the plugin's Calendly API key via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2025-14160Wordfence advisoryCode change (fix)wordpress.orgPlugin source
Recent activity
- 2026-07-10 — latest release on wordpress.org (2.0.2).
- 2025-12-12 — Cross-site request forgery (CSRF) disclosed (CVE-2025-14160), fixed in 1.2.5.
Get an email when Upcoming for Calendly has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Upcoming for Calendly (upcoming-for-calendly) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/upcoming-for-calendly (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/upcoming-for-calendly"><img src="https://laskyr.com/plugins/upcoming-for-calendly/badge.svg" alt="Upcoming for Calendly vulnerability status"></a>