Skip to content
Laskyr

Plugins · unlimited-blocks · data as of 2026-11-04

Is Unlimited Addons For Gutenberg Blocks safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.9)

As of 2026-11-04. 2 issues are on record for older versions; version 1.2.9 or newer fixes all of them that state a fix.

Latest version
1.2.9
Last updated
2026-07-02
Active installs
800+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.0+

Unlimited Blocks: WordPress Gutenberg Blocks is the editor blocks that are used to create content layouts that you can insert onto anywhere on your Wo … — by ThemeHunk

What to do

  1. Update to the latest version (1.2.9). Anything older than 1.2.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get unlimited-blocks --field=version shows what you run; wp plugin update unlimited-blocks updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-25438 · published 2026-03-19

Reflected cross-site scripting (XSS) in Unlimited Addons For Gutenberg Blocks (1.2.8 and older)

Affected
1.2.8 and older
Fixed in
1.2.9 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ThemeHunk Gutenberg Blocks unlimited-blocks allows Reflected XSS.This issue affects Gutenberg Blocks: from n/a through <= 1.2.8.

NVD CVE-2026-25438Patchstack advisory

medium 5.4 CVE-2024-44049 · published 2024-09-17

Cross-site scripting (XSS) in Unlimited Addons For Gutenberg Blocks (1.2.8 and older)

Affected
1.2.8 and older
Fixed in
1.2.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ThemeHunk Gutenberg Blocks unlimited-blocks.This issue affects Gutenberg Blocks: from n/a through <= 1.2.8.

NVD CVE-2024-44049Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Unlimited Addons For Gutenberg Blocks vulnerability status badge
<a href="https://laskyr.com/plugins/unlimited-blocks"><img src="https://laskyr.com/plugins/unlimited-blocks/badge.svg" alt="Unlimited Addons For Gutenberg Blocks vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit