Skip to content
Laskyr

Plugins · unify · data as of 2026-11-04

Is Unify safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.4.10)

As of 2026-11-04. 2 issues are on record for older versions; version 3.4.10 or newer fixes all of them that state a fix.

Latest version
3.4.10
Last updated
2026-01-27
Active installs
90+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 5.6+

A CRM payment plugin which enables connectivity with Sticky.io (Formally Limelight)/Konnektive CRM and many more. — by CodeClouds

What to do

  1. Update to the latest version (3.4.10). Anything older than 3.4.10 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get unify --field=version shows what you run; wp plugin update unify updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-13529 · published 2026-01-07

Missing authorization check in Unify (3.4.9 and older)

Affected
3.4.9 and older
Fixed in
3.4.10 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Unify plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'init' action in all versions up to, and including, 3.4.9. This makes it possible for unauthenticated attackers to delete specific plugin options via the 'unify_plugin_downgrade' parameter.

NVD CVE-2025-13529Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2025-9130 · published 2025-10-03

Stored cross-site scripting (XSS) in Unify (3.4.7 and older)

Affected
3.4.7 and older
Fixed in
3.4.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Unify plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin for WordPress's unify_checkout shortcode in all versions up to, and including, 3.4.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-9130Wordfence advisorywordpress.orgPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Unify vulnerability status badge
<a href="https://laskyr.com/plugins/unify"><img src="https://laskyr.com/plugins/unify/badge.svg" alt="Unify vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit