Plugins · under-construction-page · data as of 2026-11-01
Is Under Construction safe? Known vulnerabilities and latest version
- Latest version
- 5.83
- Last updated
- 2026-09-18
- Active installs
- 600,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.2+
Easy to use Under Construction Page & Coming Soon Page. Enable Under Construction Mode in seconds & show you're Under Construction! — by WebFactory
What to do
- Update to the latest version (5.83). Anything older than 5.83 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get under-construction-page --field=version shows what you run; wp plugin update under-construction-page updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-81295 · published 2026-09-03
Cross-site scripting (XSS) in Under Construction (5.82 and older)
- Affected
- 5.82 and older
- Fixed in
- 5.83
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Under Construction <= 5.82 versions.
medium 4.3 CVE-2023-0831 · published 2023-06-09
Cross-site request forgery (CSRF) in Under Construction (3.96 and older)
- Affected
- 3.96 and older
- Fixed in
- 3.97 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Under Construction plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.96. This is due to missing or incorrect nonce validation on the dismiss_notice function called via the admin_action_ucp_dismiss_notice action. This makes it possible for unauthenticated attackers to dismiss plugin notifications via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
medium 4.3 CVE-2023-0832 · published 2023-06-09
Cross-site request forgery (CSRF) in Under Construction (3.96 and older)
- Affected
- 3.96 and older
- Fixed in
- 3.97 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Under Construction plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.96. This is due to missing or incorrect nonce validation on the install_weglot function called via the admin_action_install_weglot action. This makes it possible for unauthenticated attackers to perform an unauthorized install of the Weglot Translate plugin via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Recent activity
- 2026-09-18 — latest release on wordpress.org (5.83).
- 2026-09-03 — Cross-site scripting (XSS) disclosed (CVE-2026-81295), fixed in 5.83.
- 2023-06-09 — Cross-site request forgery (CSRF) disclosed (CVE-2023-0831), fixed in 3.97.
- 2023-06-09 — Cross-site request forgery (CSRF) disclosed (CVE-2023-0832), fixed in 3.97.
Get an email when Under Construction has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Under Construction (under-construction-page) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/under-construction-page (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/under-construction-page"><img src="https://laskyr.com/plugins/under-construction-page/badge.svg" alt="Under Construction vulnerability status"></a>