Skip to content
Laskyr

Plugins · ultimate-reviews · data as of 2026-11-04

Is Ultimate Reviews safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.3.1)

As of 2026-11-04. 5 issues are on record for older versions; version 3.2.17 or newer fixes all of them that state a fix.

Latest version
3.3.1
Last updated
2026-10-13
Active installs
400+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4

Collect and display reviews with blocks or shortcodes. Includes powerful WooCommerce and AI features. — by Rustaurius

What to do

  1. Update to the latest version (3.3.1). Anything older than 3.2.17 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ultimate-reviews --field=version shows what you run; wp plugin update ultimate-reviews updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-24634 · published 2026-01-23

Missing authorization check in Ultimate Reviews (3.2.16 and older)

Affected
3.2.16 and older
Fixed in
3.2.17
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Authorization Bypass Through User-Controlled Key vulnerability in Rustaurius Ultimate Reviews ultimate-reviews allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Ultimate Reviews: from n/a through <= 3.2.16.

NVD CVE-2026-24634Patchstack advisory

high 7.1 CVE-2025-49266 · published 2025-06-17

Reflected cross-site scripting (XSS) in Ultimate Reviews (3.2.14 and older)

Affected
3.2.14 and older
Fixed in
3.2.15
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Rustaurius Ultimate Reviews ultimate-reviews allows Reflected XSS.This issue affects Ultimate Reviews: from n/a through <= 3.2.14.

NVD CVE-2025-49266Patchstack advisory

medium 6.1 CVE-2024-25597 · published 2024-03-15

Stored cross-site scripting (XSS) in Ultimate Reviews (3.2.8 and older)

Affected
3.2.8 and older
Fixed in
3.2.9
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Etoile Web Design Ultimate Reviews allows Stored XSS.This issue affects Ultimate Reviews: from n/a through 3.2.8.

NVD CVE-2024-25597Patchstack advisory

critical 9.8 CVE-2020-36726 · published 2023-06-07

PHP object injection in Ultimate Reviews (older than 2.1.33)

Affected
older than 2.1.33
Fixed in
2.1.33
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Ultimate Reviews plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 2.1.32 via deserialization of untrusted input in several vulnerable functions. This allows unauthenticated attackers to inject a PHP Object. No POP chain is present in the vulnerable plugin.

NVD CVE-2020-36726Wordfence advisoryCode change (fix)blog.nintechnet.com

medium 4.8 CVE-2022-23979 · published 2022-01-28

Stored cross-site scripting (XSS) in Ultimate Reviews (3.0.15 and older)

Affected
3.0.15 and older
Fixed in
3.0.16 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

Authenticated (admin+) Stored Cross-Site Scripting (XSS) vulnerability discovered in Ultimate Reviews WordPress plugin (versions <= 3.0.15).

NVD CVE-2022-23979Patchstack advisorywordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Ultimate Reviews vulnerability status badge
<a href="https://laskyr.com/plugins/ultimate-reviews"><img src="https://laskyr.com/plugins/ultimate-reviews/badge.svg" alt="Ultimate Reviews vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit