Plugins · ultimate-post-kit · data as of 2026-11-04
Is Ultimate Post Kit safe? Known vulnerabilities and latest version
- Latest version
- 4.6.0
- Last updated
- 2026-10-26
- Active installs
- 30,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Build WordPress blog, magazine, news, archive and single-post layouts with Elementor post grid, carousel, slider and list widgets. — by bdthemes
What to do
- Update to the latest version (4.6.0). Anything older than 4.5.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get ultimate-post-kit --field=version shows what you run; wp plugin update ultimate-post-kit updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-105886 · published 2026-10-08
Missing authorization check in Ultimate Post Kit (4.5.5 and older)
- Affected
- 4.5.5 and older
- Fixed in
- 4.5.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in BdThemes Ultimate Post Kit ultimate-post-kit allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Ultimate Post Kit: from n/a through 4.5.5.
medium 6.4 CVE-2026-24362 · published 2026-03-25
Missing authorization check in Ultimate Post Kit (4.0.21 and older)
- Affected
- 4.0.21 and older
- Fixed in
- 4.0.22
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in bdthemes Ultimate Post Kit ultimate-post-kit allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Ultimate Post Kit: from n/a through <= 4.0.21.
medium 6.4 CVE-2024-5662 · published 2024-06-28
Stored cross-site scripting (XSS) in Ultimate Post Kit (3.11.7 and older)
- Affected
- 3.11.7 and older
- Fixed in
- 3.11.8 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Ultimate Post Kit Addons For Elementor – (Post Grid, Post Carousel, Post Slider, Category List, Post Tabs, Timeline, Post Ticker, Tag Cloud) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘url’ parameter within the Social Count (Static) widget in all versions up to, and including, 3.11.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2024-5662Wordfence advisoryCode change (fix)wordpress.orgPlugin source
Recent activity
- 2026-10-26 — latest release on wordpress.org (4.6.0).
- 2026-10-08 — Missing authorization check disclosed (CVE-2026-105886), fixed in 4.5.6.
- 2026-03-25 — Missing authorization check disclosed (CVE-2026-24362), fixed in 4.0.22.
- 2024-06-28 — Stored cross-site scripting (XSS) disclosed (CVE-2024-5662), fixed in 3.11.8.
Get an email when Ultimate Post Kit has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Ultimate Post Kit (ultimate-post-kit) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by bdthemes (7 tracked)
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/ultimate-post-kit (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/ultimate-post-kit"><img src="https://laskyr.com/plugins/ultimate-post-kit/badge.svg" alt="Ultimate Post Kit vulnerability status"></a>