Skip to content
Laskyr

Plugins · ultimate-member-widgets-for-elementor · data as of 2026-11-04

Is MemberKits safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.0.1)

As of 2026-11-04. 2 issues are on record for older versions; version 2.4 or newer fixes all of them that state a fix.

Latest version
3.0.1
Last updated
2026-09-01
Active installs
400+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.0+

Style Ultimate Member login, register, directory, and profile pages in Elementor. — by UserElements

What to do

  1. Update to the latest version (3.0.1). Anything older than 2.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ultimate-member-widgets-for-elementor --field=version shows what you run; wp plugin update ultimate-member-widgets-for-elementor updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2025-66116 · published 2025-12-18

Information disclosure in MemberKits (2.3 and older)

Affected
2.3 and older
Fixed in
2.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Insertion of Sensitive Information Into Sent Data vulnerability in UserElements Ultimate Member Widgets for Elementor ultimate-member-widgets-for-elementor allows Retrieve Embedded Sensitive Data.This issue affects Ultimate Member Widgets for Elementor: from n/a through <= 2.3.

NVD CVE-2025-66116Patchstack advisory

medium 5.3 CVE-2025-12778 · published 2025-11-20

Missing authorization check in MemberKits (2.3 and older)

Affected
2.3 and older
Fixed in
2.4 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Ultimate Member Widgets for Elementor – WordPress User Directory plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the handle_filter_users function in all versions up to, and including, 2.3. This makes it possible for unauthenticated attackers to extract partial metadata of all WordPress users, including their first name, last name and email addresses.

NVD CVE-2025-12778Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
MemberKits vulnerability status badge
<a href="https://laskyr.com/plugins/ultimate-member-widgets-for-elementor"><img src="https://laskyr.com/plugins/ultimate-member-widgets-for-elementor/badge.svg" alt="MemberKits vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit