Plugins · ultimate-maps-by-supsystic · data as of 2026-11-04
Is Ultimate Maps by Supsystic safe? Known vulnerabilities and latest version
- Latest version
- 1.6.5
- Last updated
- 2026-10-30
- Active installs
- 10,000+
- Known issues on record
- 9
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.3+
Interactive OpenStreetMap and Leaflet maps with unlimited markers, categories and clustering. No Google API key and no requests to Google. — by supsystic
What to do
- Update to the latest version (1.6.5). Anything older than 1.6.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get ultimate-maps-by-supsystic --field=version shows what you run; wp plugin update ultimate-maps-by-supsystic updates it.
Check your version
Known vulnerabilities
9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-102397 · published 2026-09-30
Missing authorization check in Ultimate Maps by Supsystic (1.5.5 and older)
- Affected
- 1.5.5 and older
- Fixed in
- 1.6.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Access Control in Ultimate Maps by Supsystic <= 1.5.5 versions.
high 7.1 CVE-2026-102396 · published 2026-09-30
Cross-site scripting (XSS) in Ultimate Maps by Supsystic (1.5.5 and older)
- Affected
- 1.5.5 and older
- Fixed in
- 1.6.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Ultimate Maps by Supsystic <= 1.5.5 versions.
medium 5.3 CVE-2026-85309 · published 2026-09-03
Missing authorization check in Ultimate Maps by Supsystic (1.5.3 and older)
- Affected
- 1.5.3 and older
- Fixed in
- 1.5.4
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Supsystic Ultimate Maps by Supsystic allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects Ultimate Maps by Supsystic: from n/a through 1.5.3.
high 7.1 CVE-2026-73375 · published 2026-08-18
Cross-site scripting (XSS) in Ultimate Maps by Supsystic (older than 1.5.0)
- Affected
- older than 1.5.0
- Fixed in
- 1.5.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Ultimate Maps by Supsystic < 1.5.0 versions.
critical 9.8 CVE-2026-73376 · published 2026-08-18
PHP object injection in Ultimate Maps by Supsystic (older than 1.5.0)
- Affected
- older than 1.5.0
- Fixed in
- 1.5.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated PHP Object Injection in Ultimate Maps by Supsystic < 1.5.0 versions.
high 7.5 CVE-2026-73377 · published 2026-08-18
Missing authorization check in Ultimate Maps by Supsystic (older than 1.5.0)
- Affected
- older than 1.5.0
- Fixed in
- 1.5.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Access Control in Ultimate Maps by Supsystic < 1.5.0 versions.
medium 4.3 CVE-2024-31271 · published 2024-04-12
Cross-site request forgery (CSRF) in Ultimate Maps by Supsystic (1.2.16 and older)
- Affected
- 1.2.16 and older
- Fixed in
- 1.2.17
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Supsystic Ultimate Maps by Supsystic.This issue affects Ultimate Maps by Supsystic: from n/a through 1.2.16.
medium 4.8 CVE-2023-6732 · published 2024-01-16
Cross-site scripting (XSS) in Ultimate Maps by Supsystic (older than 1.2.16)
- Affected
- older than 1.2.16
- Fixed in
- 1.2.16
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Ultimate Maps by Supsystic WordPress plugin before 1.2.16 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
medium 6.1 CVE-2021-24274 · published 2021-05-05
Reflected cross-site scripting (XSS) in Ultimate Maps by Supsystic (older than 1.2.5)
- Affected
- older than 1.2.5
- Fixed in
- 1.2.5
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The Ultimate Maps by Supsystic WordPress plugin before 1.2.5 did not sanitise the tab parameter of its options page before outputting it in an attribute, leading to a reflected Cross-Site Scripting issue
Recent activity
- 2026-10-30 — latest release on wordpress.org (1.6.5).
- 2026-09-30 — Missing authorization check disclosed (CVE-2026-102397), fixed in 1.6.1.
- 2026-09-30 — Cross-site scripting (XSS) disclosed (CVE-2026-102396), fixed in 1.6.1.
- 2026-09-03 — Missing authorization check disclosed (CVE-2026-85309), fixed in 1.5.4.
Get an email when Ultimate Maps by Supsystic has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Ultimate Maps by Supsystic (ultimate-maps-by-supsystic) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by supsystic (6 tracked)
Types found in this plugin: Cross-site scripting (XSS) (4) · Missing authorization (3) · PHP object injection (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/ultimate-maps-by-supsystic (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/ultimate-maps-by-supsystic"><img src="https://laskyr.com/plugins/ultimate-maps-by-supsystic/badge.svg" alt="Ultimate Maps by Supsystic vulnerability status"></a>