Skip to content
Laskyr

Plugins · ultimate-flipbox-addon-for-elementor · data as of 2026-11-04

Is Flipbox Addon for Elementor safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1.8)

As of 2026-11-04. 2 issues are on record for older versions; version 2.1.0 or newer fixes all of them that state a fix.

Latest version
2.1.8
Last updated
2026-10-30
Active installs
600+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 6.0+

Flip Boxes for Elementor – animated, 3D, responsive flip box widgets for posts, custom post types, portfolios, and product showcases. — by Dragwyb

What to do

  1. Update to the latest version (2.1.8). Anything older than 2.1.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ultimate-flipbox-addon-for-elementor --field=version shows what you run; wp plugin update ultimate-flipbox-addon-for-elementor updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-6048 · published 2026-04-18

Stored cross-site scripting (XSS) in Flipbox Addon for Elementor (2.0.8 and older)

Affected
2.0.8 and older
Fixed in
2.1.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Flipbox Addon for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Flipbox widget's button URL `custom_attributes` field in all versions up to, and including, 2.1.1 due to insufficient validation of custom attribute names. Specifically, the plugin uses `esc_html()` on the attribute name which does not prevent event handler attributes (e.g., `onmouseover`, `onclick`). This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-6048Wordfence advisoryPlugin source

medium 6.5 CVE-2024-51870 · published 2024-11-19

Stored cross-site scripting (XSS) in Flipbox Addon for Elementor (1.0.4 and older)

Affected
1.0.4 and older
Fixed in
1.0.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in dragwyb Ultimate Flipbox Addon for Elementor ultimate-flipbox-addon-for-elementor allows Stored XSS.This issue affects Ultimate Flipbox Addon for Elementor: from n/a through 1.0.4.

NVD CVE-2024-51870Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Flipbox Addon for Elementor vulnerability status badge
<a href="https://laskyr.com/plugins/ultimate-flipbox-addon-for-elementor"><img src="https://laskyr.com/plugins/ultimate-flipbox-addon-for-elementor/badge.svg" alt="Flipbox Addon for Elementor vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit