Plugins · ultimate-faqs · data as of 2026-11-04
Is Ultimate FAQ Accordion Plugin safe? Known vulnerabilities and latest version
- Latest version
- 2.6.0
- Last updated
- 2026-10-13
- Active installs
- 30,000+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Full-featured FAQ and accordion plugin with advanced search, simple UI and easy-to-use FAQ blocks and shortcodes. — by Rustaurius
What to do
- Update to the latest version (2.6.0). Anything older than 2.5.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get ultimate-faqs --field=version shows what you run; wp plugin update ultimate-faqs updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-94391 · published 2026-09-23
Cross-site scripting (XSS) in Ultimate FAQ Accordion Plugin (2.4.14 and older)
- Affected
- 2.4.14 and older
- Fixed in
- 2.5.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Contributor Cross Site Scripting (XSS) in Ultimate FAQ <= 2.4.14 versions.
medium 6.4 CVE-2026-4336 · published 2026-04-09
Stored cross-site scripting (XSS) in Ultimate FAQ Accordion Plugin (2.4.7 and older)
- Affected
- 2.4.7 and older
- Fixed in
- 2.4.8 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Ultimate FAQ Accordion plugin for WordPress is vulnerable to Stored Cross-Site Scripting via FAQ content in all versions up to, and including, 2.4.7. This is due to the plugin calling html_entity_decode() on post_content during rendering in the set_display_variables() function (View.FAQ.class.php, line 746), which converts HTML entity-encoded payloads back into executable HTML, combined with insufficient output escaping in the faq-answer.php template where the decoded content is echoed without wp_kses_post() or any other sanitization. The ufaq custom post type is registered with 'show_in_rest' => true and defaults to 'post' capability_type, allowing Author-level users to create and publish FAQs via the REST API. An Author can submit entity-encoded malicious HTML (e.g., <img src=x onerror=alert()>) which bypasses WordPress's kses sanitization at save time (since kses sees entities as plain text, not tags), but is then decoded back into executable HTML by html_entity_decode() at render time. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in FAQ pages that will execute whenever a user accesses an injected FAQ, either directly or via the [ultimate-faqs] shortcode.
NVD CVE-2026-4336Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2025-67590 · published 2025-12-09
Cross-site request forgery (CSRF) in Ultimate FAQ Accordion Plugin (2.4.3 and older)
- Affected
- 2.4.3 and older
- Fixed in
- 2.4.4
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Rustaurius Ultimate FAQ ultimate-faqs allows Cross Site Request Forgery.This issue affects Ultimate FAQ: from n/a through <= 2.4.3.
medium 6.1 CVE-2020-7107 · published 2020-01-16
Cross-site scripting (XSS) in Ultimate FAQ Accordion Plugin (older than 1.8.30)
- Affected
- older than 1.8.30
- Fixed in
- 1.8.30
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The Ultimate FAQ plugin before 1.8.30 for WordPress allows XSS via Display_FAQ to Shortcodes/DisplayFAQs.php.
high 7.5 CVE-2019-17232 · published 2019-10-07
Authentication bypass in Ultimate FAQ Accordion Plugin (1.8.24 and older)
- Affected
- 1.8.24 and older
- Fixed in
- 1.8.25 *
- Access needed (per CVSS)
- No login needed
- Range from
- advisory text · score by NVD
Details from the advisory
Functions/EWD_UFAQ_Import.php in the ultimate-faqs plugin through 1.8.24 for WordPress allows unauthenticated options import.
NVD CVE-2019-17232wordpress.orgblog.nintechnet.comwpvulndb.com
medium 6.1 CVE-2019-17233 · published 2019-10-07
Content injection in Ultimate FAQ Accordion Plugin (1.8.24 and older)
- Affected
- 1.8.24 and older
- Fixed in
- 1.8.25 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
Functions/EWD_UFAQ_Import.php in the ultimate-faqs plugin through 1.8.24 for WordPress allows HTML content injection.
NVD CVE-2019-17233wordpress.orgblog.nintechnet.comwpvulndb.com
medium 6.1 CVE-2019-15643 · published 2019-08-27
Cross-site scripting (XSS) in Ultimate FAQ Accordion Plugin (older than 1.8.22)
- Affected
- older than 1.8.22
- Fixed in
- 1.8.22
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The ultimate-faqs plugin before 1.8.22 for WordPress has XSS.
Recent activity
- 2026-10-13 — latest release on wordpress.org (2.6.0).
- 2026-09-23 — Cross-site scripting (XSS) disclosed (CVE-2026-94391), fixed in 2.5.0.
- 2026-04-09 — Stored cross-site scripting (XSS) disclosed (CVE-2026-4336), fixed in 2.4.8.
- 2025-12-09 — Cross-site request forgery (CSRF) disclosed (CVE-2025-67590), fixed in 2.4.4.
Get an email when Ultimate FAQ Accordion Plugin has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Ultimate FAQ Accordion Plugin (ultimate-faqs) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Rustaurius (7 tracked)
Types found in this plugin: Cross-site scripting (XSS) (4) · Cross-site request forgery (CSRF) (1) · Authentication bypass (1) · Content injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/ultimate-faqs (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/ultimate-faqs"><img src="https://laskyr.com/plugins/ultimate-faqs/badge.svg" alt="Ultimate FAQ Accordion Plugin vulnerability status"></a>