Skip to content
Laskyr

Plugins · uicore-elements · data as of 2026-11-04

Is UiCore Elements safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.18)

As of 2026-11-04. 4 issues are on record for older versions; version 1.3.18 or newer fixes all of them that state a fix.

Latest version
1.3.18
Last updated
2026-09-24
Active installs
40,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Enhance your website with UiCore Elements – a free plugin offering diverse widgets for effortless design enrichment. — by uicore

What to do

  1. Update to the latest version (1.3.18). Anything older than 1.3.18 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get uicore-elements --field=version shows what you run; wp plugin update uicore-elements updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-39708 · published 2026-04-08

Stored cross-site scripting (XSS) in UiCore Elements (1.3.17 and older)

Affected
1.3.17 and older
Fixed in
1.3.18
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in UiCore UiCore Elements uicore-elements allows Stored XSS.This issue affects UiCore Elements: from n/a through 1.3.17.

NVD CVE-2026-39708Patchstack advisory

medium 6.5 CVE-2025-58196 · published 2025-08-27

Stored cross-site scripting (XSS) in UiCore Elements (1.3.4 and older)

Affected
1.3.4 and older
Fixed in
1.3.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in uicore UiCore Elements uicore-elements allows Stored XSS.This issue affects UiCore Elements: from n/a through <= 1.3.4.

NVD CVE-2025-58196Patchstack advisory

high 7.5 CVE-2025-6253 · published 2025-08-12

Path traversal / file read in UiCore Elements (1.3.0 and older)

Affected
1.3.0 and older
Fixed in
1.3.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The UiCore Elements – Free Elementor widgets and templates plugin for WordPress is vulnerable to Arbitrary File Read in all versions up to, and including, 1.3.0 via the prepare_template() function due to a missing capability check and insufficient controls on the filename specified. This makes it possible for unauthenticated attackers to read the contents of arbitrary files on the server, which can contain sensitive information.

NVD CVE-2025-6253Wordfence advisoryCode change (fix)

medium 6.4 CVE-2025-1054 · published 2025-04-23

Stored cross-site scripting (XSS) in UiCore Elements (1.0.16 and older)

Affected
1.0.16 and older
Fixed in
1.2.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The UiCore Elements – Free Elementor widgets and templates plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the UI Counter, UI Icon Box, UI Testimonial Slider, UI Testimonial Grid, and UI Testimonial Carousel widgets in all versions up to, and including, 1.0.16 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-1054Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
UiCore Elements vulnerability status badge
<a href="https://laskyr.com/plugins/uicore-elements"><img src="https://laskyr.com/plugins/uicore-elements/badge.svg" alt="UiCore Elements vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit