Skip to content
Laskyr

Plugins · udimi-optin · data as of 2026-11-04

Is Udimi Tools safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.2.3)

As of 2026-11-04. 1 issue is on record for older versions; version 3.2.1 or newer fixes all of them that state a fix.

Latest version
3.2.3
Last updated
2026-05-22
Active installs
20+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.0+

This plugin automatically inserts Udimi tracking code, Udimi Lead Boxes, or Buy Solo Ad forms to your site. — by webocoders

What to do

  1. Update to the latest version (3.2.3). Anything older than 3.2.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get udimi-optin --field=version shows what you run; wp plugin update udimi-optin updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-7456 · published 2026-08-05

Missing authorization check in Udimi Tools (3.2 and older)

Affected
3.2 and older
Fixed in
3.2.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Udimi Tools plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the `ajax_disconnect()` function in all versions up to, and including, 3.2. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete the plugin's six configuration options — including the API key, connected Udimi user email, and tracking-script payload — effectively disconnecting the site from the configured Udimi account. The companion `ajax_connect()` handler is missing the same checks, allowing the same low-privilege attackers to overwrite those options with an attacker-supplied API key.

NVD CVE-2026-7456Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Udimi Tools vulnerability status badge
<a href="https://laskyr.com/plugins/udimi-optin"><img src="https://laskyr.com/plugins/udimi-optin/badge.svg" alt="Udimi Tools vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit