Skip to content
Laskyr

Plugins · twentig · data as of 2026-11-04

Is Twentig Supercharged Block Editor safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.6)

As of 2026-11-04. 1 issue is on record for older versions; version 2.0-beta.1 or newer fixes all of them that state a fix.

Latest version
2.0.6
Last updated
2026-10-15
Active installs
20,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Supercharge the WordPress block editor with enhanced core blocks, hundreds of block patterns, professional starter sites, and portfolio tools. — by Twentig

What to do

  1. Update to the latest version (2.0.6). Anything older than 2.0-beta.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get twentig --field=version shows what you run; wp plugin update twentig updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-2602 · published 2026-03-29

Stored cross-site scripting (XSS) in Twentig Supercharged Block Editor (1.9.7 and older)

Affected
1.9.7 and older
Fixed in
2.0-beta.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Twentig plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'featuredImageSizeWidth' parameter in versions up to, and including, 1.9.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-2602Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Twentig Supercharged Block Editor vulnerability status badge
<a href="https://laskyr.com/plugins/twentig"><img src="https://laskyr.com/plugins/twentig/badge.svg" alt="Twentig Supercharged Block Editor vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit