Plugins · tutor-lms-elementor-addons · data as of 2026-11-04
Is Tutor LMS Elementor Addons safe? Known vulnerabilities and latest version
- Latest version
- 4.0.2
- Last updated
- 2026-09-18
- Active installs
- 30,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Get 35+ Elementor widgets to create an entire eLearning site with Tutor LMS and design custom course pages, course carousels, listings, and more. — by Themeum
What to do
- Update to the latest version (4.0.2). Anything older than 4.0.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get tutor-lms-elementor-addons --field=version shows what you run; wp plugin update tutor-lms-elementor-addons updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-1372 · published 2026-07-21
Missing authorization check in Tutor LMS Elementor Addons (4.0.0 and older)
- Affected
- 4.0.0 and older
- Fixed in
- 4.0.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Tutor LMS Elementor Addons plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 4.0.0 This is due to missing capability checks on the `activate_tutor_free()` and `activate_elementor_free()` functions registered as `admin_action_*` handlers. This makes it possible for authenticated attackers, with Subscriber-level access and above, to activate the Tutor LMS and Elementor plugins without proper authorization.
NVD CVE-2026-1372Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2025-63042 · published 2025-12-09
Stored cross-site scripting (XSS) in Tutor LMS Elementor Addons (3.0.1 and older)
- Affected
- 3.0.1 and older
- Fixed in
- 3.0.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Themeum Tutor LMS Elementor Addons tutor-lms-elementor-addons allows Stored XSS.This issue affects Tutor LMS Elementor Addons: from n/a through <= 3.0.1.
high 8.8 CVE-2024-53816 · published 2024-12-09
Missing authorization check in Tutor LMS Elementor Addons (2.1.5 and older)
- Affected
- 2.1.5 and older
- Fixed in
- 2.1.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Missing Authorization vulnerability in Themeum Tutor LMS Elementor Addons tutor-lms-elementor-addons.This issue affects Tutor LMS Elementor Addons: from n/a through <= 2.1.5.
medium 4.3 CVE-2024-10897 · published 2024-11-15
Missing authorization check in Tutor LMS Elementor Addons (2.1.5 and older)
- Affected
- 2.1.5 and older
- Fixed in
- 2.1.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Tutor LMS Elementor Addons plugin for WordPress is vulnerable to unauthorized plugin installation due to a missing capability check on the install_etlms_dependency_plugin() function in all versions up to, and including, 2.1.5. This makes it possible for authenticated attackers, with Subscriber-level access and above, to install Elementor or Tutor LMS. Please note the impact of this issue is incredibly limited due to the fact that these two plugins will likely already be installed as a dependency of the plugin.
NVD CVE-2024-10897Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2024-5576 · published 2024-08-20
Stored cross-site scripting (XSS) in Tutor LMS Elementor Addons (2.1.4 and older)
- Affected
- 2.1.4 and older
- Fixed in
- 2.1.5 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Tutor LMS Elementor Addons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'course_carousel_skin' attribute within the plugin's Course Carousel widget in all versions up to, and including, 2.1.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2024-5576Wordfence advisoryCode change (fix)wordpress.orgPlugin source
medium 5.4 CVE-2024-29913 · published 2024-03-27
Stored cross-site scripting (XSS) in Tutor LMS Elementor Addons (2.1.3 and older)
- Affected
- 2.1.3 and older
- Fixed in
- 2.1.4
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Themeum Tutor LMS Elementor Addons allows Stored XSS.This issue affects Tutor LMS Elementor Addons: from n/a through 2.1.3.
Recent activity
- 2026-09-18 — latest release on wordpress.org (4.0.2).
- 2026-07-21 — Missing authorization check disclosed (CVE-2026-1372), fixed in 4.0.1.
- 2025-12-09 — Stored cross-site scripting (XSS) disclosed (CVE-2025-63042), fixed in 3.0.2.
- 2024-12-09 — Missing authorization check disclosed (CVE-2024-53816), fixed in 2.1.6.
Get an email when Tutor LMS Elementor Addons has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Tutor LMS Elementor Addons (tutor-lms-elementor-addons) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Themeum (7 tracked)
Types found in this plugin: Missing authorization (3) · Cross-site scripting (XSS) (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/tutor-lms-elementor-addons (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/tutor-lms-elementor-addons"><img src="https://laskyr.com/plugins/tutor-lms-elementor-addons/badge.svg" alt="Tutor LMS Elementor Addons vulnerability status"></a>