Skip to content
Laskyr

Plugins · tune-library · data as of 2026-11-04

Is Tune Library safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.6.4)

As of 2026-11-04. 2 issues are on record for older versions; version 1.6.4 or newer fixes all of them that state a fix.

Latest version
1.6.4
Last updated
2026-02-01
Active installs
20+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11

Import your iTunes music list into Wordpress and display your song collection on any page. — by Yannick Lefebvre

What to do

  1. Update to the latest version (1.6.4). Anything older than 1.6.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get tune-library --field=version shows what you run; wp plugin update tune-library updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-1401 · published 2026-02-06

Stored cross-site scripting (XSS) in Tune Library (1.6.3 and older)

Affected
1.6.3 and older
Fixed in
1.6.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Tune Library plugin for WordPress is vulnerable to Stored Cross-Site Scripting via CSV import in all versions up to, and including, 1.6.3. This is due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the injected page. The vulnerability exists because the CSV import functionality lacks authorization checks and doesn't sanitize imported data, which is later rendered without escaping through the [tune-library] shortcode.

NVD CVE-2026-1401Wordfence advisoryCode change (fix)Plugin source

high 8.1 CVE-2015-3314 · published 2017-09-07

SQL injection in Tune Library (1.5.4 and older)

Affected
1.5.4 and older
Fixed in
1.6.3 *
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

SQL injection vulnerability in WordPress Tune Library plugin before 1.5.5.

NVD CVE-2015-3314wordpress.orgpacketstormsecurity.comopenwall.comopenwall.comsecurityfocus.comexploit-db.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Tune Library vulnerability status badge
<a href="https://laskyr.com/plugins/tune-library"><img src="https://laskyr.com/plugins/tune-library/badge.svg" alt="Tune Library vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit