Plugins · tumult-hype-animations · data as of 2026-11-04
Is Tumult Hype Animations safe? Known vulnerabilities and latest version
- Latest version
- 1.9.20
- Last updated
- 2026-10-15
- Active installs
- 1,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
This plugin allows you to upload your Tumult Hype animations to your Wordpress site to easily embed them using shortcodes on posts and pages. — by tumultinc
What to do
- Update to the latest version (1.9.20). Anything older than 1.9.17 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get tumult-hype-animations --field=version shows what you run; wp plugin update tumult-hype-animations updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2024-30461 · published 2026-01-05
Cross-site scripting (XSS) in Tumult Hype Animations (1.9.11 and older)
- Affected
- 1.9.11 and older
- Fixed in
- 1.9.12
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Tumult Inc Tumult Hype Animations allows DOM-Based XSS.This issue affects Tumult Hype Animations: from n/a through 1.9.11.
critical 9.9 CVE-2024-11082 · published 2024-11-28
Arbitrary file upload in Tumult Hype Animations (1.9.15 and older)
- Affected
- 1.9.15 and older
- Fixed in
- 1.9.17 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Tumult Hype Animations plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the hypeanimations_panel() function in all versions up to, and including, 1.9.15. This makes it possible for authenticated attackers, with Author-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible.
NVD CVE-2024-11082Wordfence advisoryCode change (fix)wordpress.orggithub.comPlugin source
medium 4.3 CVE-2024-10543 · published 2024-11-06
Missing authorization check in Tumult Hype Animations (1.9.14 and older)
- Affected
- 1.9.14 and older
- Fixed in
- 1.9.17 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Tumult Hype Animations plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the hypeanimations_getcontent function in all versions up to, and including, 1.9.14. This makes it possible for authenticated attackers, with Subscriber-level access and above, to retrieve animation information.
medium 4.3 CVE-2024-30460 · published 2024-03-29
Cross-site request forgery (CSRF) in Tumult Hype Animations (1.9.11 and older)
- Affected
- 1.9.11 and older
- Fixed in
- 1.9.12
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Tumult Inc Tumult Hype Animations.This issue affects Tumult Hype Animations: from n/a through 1.9.11.
critical 9.1 CVE-2024-2890 · published 2024-03-28
Arbitrary file upload in Tumult Hype Animations (1.9.12 and older)
- Affected
- 1.9.12 and older
- Fixed in
- 1.9.13
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unrestricted Upload of File with Dangerous Type vulnerability in Tumult Inc. Tumult Hype Animations.This issue affects Tumult Hype Animations: from n/a through 1.9.12.
Recent activity
- 2026-10-15 — latest release on wordpress.org (1.9.20).
- 2026-01-05 — Cross-site scripting (XSS) disclosed (CVE-2024-30461), fixed in 1.9.12.
- 2024-11-28 — Arbitrary file upload disclosed (CVE-2024-11082), fixed in 1.9.17.
- 2024-11-06 — Missing authorization check disclosed (CVE-2024-10543), fixed in 1.9.17.
Get an email when Tumult Hype Animations has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Tumult Hype Animations (tumult-hype-animations) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Arbitrary file upload (2) · Cross-site scripting (XSS) (1) · Missing authorization (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/tumult-hype-animations (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/tumult-hype-animations"><img src="https://laskyr.com/plugins/tumult-hype-animations/badge.svg" alt="Tumult Hype Animations vulnerability status"></a>