Plugins · trusted-shops-easy-integration-for-woocommerce · data as of 2026-11-04
Is Trusted Shops Easy Integration for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 2.0.8
- Last updated
- 2026-09-14
- Active installs
- 6,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
Show that your customers love you with reviews in your online store and boost your business with the free Trusted Shops Plugin for WooCommerce. — by vendidero
What to do
- Update to the latest version (2.0.8). Anything older than 2.0.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get trusted-shops-easy-integration-for-woocommerce --field=version shows what you run; wp plugin update trusted-shops-easy-integration-for-woocommerce updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-96816 · published 2026-09-30
Cross-site scripting (XSS) in Trusted Shops Easy Integration for WooCommerce (2.0.6 and older)
- Affected
- 2.0.6 and older
- Fixed in
- 2.0.7
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Trusted Shops Easy Integration for WooCommerce <= 2.0.6 versions.
Recent activity
- 2026-09-14 — latest release on wordpress.org (2.0.8).
- 2026-09-30 — Cross-site scripting (XSS) disclosed (CVE-2026-96816), fixed in 2.0.7.
Get an email when Trusted Shops Easy Integration for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Trusted Shops Easy Integration for WooCommerce (trusted-shops-easy-integration-for-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by vendidero (3 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/trusted-shops-easy-integration-for-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/trusted-shops-easy-integration-for-woocommerce"><img src="https://laskyr.com/plugins/trusted-shops-easy-integration-for-woocommerce/badge.svg" alt="Trusted Shops Easy Integration for WooCommerce vulnerability status"></a>