Skip to content
Laskyr

Plugins · triplea-cryptocurrency-payment-gateway-for-woocommerce · data as of 2026-11-04

Is Cryptocurrency Payment Gateway for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.28)

As of 2026-11-04. 1 issue is on record for older versions; version 2.0.26 or newer fixes all of them that state a fix.

Latest version
2.0.28
Last updated
2026-03-06
Active installs
200+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.0+

Start accepting crypto payments on your store with our secure and easy-setup white-label crypto payments plugin. — by Triple-A.io

What to do

  1. Update to the latest version (2.0.28). Anything older than 2.0.26 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get triplea-cryptocurrency-payment-gateway-for-woocommerce --field=version shows what you run; wp plugin update triplea-cryptocurrency-payment-gateway-for-woocommerce updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-12392 · published 2025-11-18

Missing authorization check in Cryptocurrency Payment Gateway for WooCommerce (2.0.25 and older)

Affected
2.0.25 and older
Fixed in
2.0.26 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Cryptocurrency Payment Gateway for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'handle_optin_optout' function in all versions up to, and including, 2.0.25. This makes it possible for unauthenticated attackers to opt in and out of tracking.

NVD CVE-2025-12392Wordfence advisoryCode change (fix)wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Cryptocurrency Payment Gateway for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/triplea-cryptocurrency-payment-gateway-for-woocommerce"><img src="https://laskyr.com/plugins/triplea-cryptocurrency-payment-gateway-for-woocommerce/badge.svg" alt="Cryptocurrency Payment Gateway for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit