Skip to content
Laskyr

Plugins · trinity-audio · data as of 2026-11-04

Is Trinity Audio safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.28.2)

As of 2026-11-04. 5 issues are on record for older versions; version 5.24 or newer fixes all of them that state a fix.

Latest version
5.28.2
Last updated
2026-10-19
Active installs
2,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

The audio player will convert your content into audio in just a few clicks, with one-time seamless integration (no support, or special tech knowledge … — by sergiotrinity

What to do

  1. Update to the latest version (5.28.2). Anything older than 5.24 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get trinity-audio --field=version shows what you run; wp plugin update trinity-audio updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-67466 · published 2025-12-09

Missing authorization check in Trinity Audio (5.23.3 and older)

Affected
5.23.3 and older
Fixed in
5.24
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in sergiotrinity Trinity Audio trinity-audio allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Trinity Audio: from n/a through <= 5.23.3.

NVD CVE-2025-67466Patchstack advisory

medium 5.3 CVE-2025-9196 · published 2025-10-11

Information disclosure in Trinity Audio (5.21.0 and older)

Affected
5.21.0 and older
Fixed in
5.22.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Trinity Audio – Text to Speech AI audio player to convert content into audio plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 5.21.0 via the ~/admin/inc/phpinfo.php file that gets created on install. This makes it possible for unauthenticated attackers to extract sensitive data including configuration data.

NVD CVE-2025-9196Wordfence advisoryCode change (fix)

medium 4.3 CVE-2025-9886 · published 2025-10-04

Cross-site request forgery (CSRF) in Trinity Audio (5.20.2 and older)

Affected
5.20.2 and older
Fixed in
5.21.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Trinity Audio – Text to Speech AI audio player to convert content into audio plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 5.20.2. This is due to missing or incorrect nonce validation in the '/admin/inc/post-management.php' file. This makes it possible for unauthenticated attackers to activate/deactivate posts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2025-9886Wordfence advisoryCode change (fix)Plugin source

medium 6.1 CVE-2025-9952 · published 2025-10-04

Reflected cross-site scripting (XSS) in Trinity Audio (5.20.2 and older)

Affected
5.20.2 and older
Fixed in
5.21.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Trinity Audio – Text to Speech AI audio player to convert content into audio plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'range-date' parameter in all versions up to, and including, 5.20.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2025-9952Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2025-49272 · published 2025-06-06

Missing authorization check in Trinity Audio (5.20.0 and older)

Affected
5.20.0 and older
Fixed in
5.20.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in sergiotrinity Trinity Audio trinity-audio allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Trinity Audio: from n/a through <= 5.20.0.

NVD CVE-2025-49272Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Trinity Audio vulnerability status badge
<a href="https://laskyr.com/plugins/trinity-audio"><img src="https://laskyr.com/plugins/trinity-audio/badge.svg" alt="Trinity Audio vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit