Plugins · travelpayouts · data as of 2026-11-04
Is Travelpayouts safe? Known vulnerabilities and latest version
- Status
- Closed 2026-10-28
- Known issues on record
- 4
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate travelpayouts && wp plugin delete travelpayouts
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 4 record(s) do not state which versions are affected.
medium 6.5 CVE-2025-68042 · published 2026-02-20
Missing authorization check in Travelpayouts (1.2.2 and older)
- Affected
- 1.2.2 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Travelpayouts Travelpayouts travelpayouts allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Travelpayouts: from n/a through <= 1.2.2.
medium 4.8 CVE-2023-5932 · published 2025-05-15
Reflected cross-site scripting (XSS) in Travelpayouts (older than 1.1.14)
- Affected
- older than 1.1.14
- Fixed in
- 1.1.14
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Travelpayouts: All Travel Brands in One Place WordPress plugin before 1.1.14 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
high 7.3 CVE-2023-5934 · published 2025-05-15
Cross-site request forgery (CSRF) in Travelpayouts (older than 1.1.13)
- Affected
- older than 1.1.13
- Fixed in
- 1.1.13
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Travelpayouts: All Travel Brands in One Place WordPress plugin before 1.1.13 does not have CSRF check in place when importing settings from the v1, which could allow attackers to make a logged in admin update some settings via a CSRF attack
medium 6.1 CVE-2024-0337 · published 2024-03-20
Open redirect in Travelpayouts (1.1.15 and older)
- Affected
- 1.1.15 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Travelpayouts: All Travel Brands in One Place WordPress plugin through 1.1.15 is vulnerable to Open Redirect due to insufficient validation on the travelpayouts_redirect variable. This makes it possible for unauthenticated attackers to redirect users to potentially malicious sites if they can successfully trick them into performing an action.
Recent activity
- 2026-10-28 — closed on wordpress.org.
- 2026-02-20 — Missing authorization check disclosed (CVE-2025-68042), fix version not stated.
- 2025-05-15 — Reflected cross-site scripting (XSS) disclosed (CVE-2023-5932), fixed in 1.1.14.
- 2025-05-15 — Cross-site request forgery (CSRF) disclosed (CVE-2023-5934), fixed in 1.1.13.
Get an email when Travelpayouts has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Travelpayouts (travelpayouts) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Cross-site scripting (XSS) (1) · Cross-site request forgery (CSRF) (1) · Open redirect (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/travelpayouts (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/travelpayouts"><img src="https://laskyr.com/plugins/travelpayouts/badge.svg" alt="Travelpayouts vulnerability status"></a>