Skip to content
Laskyr

Plugins · travelfic-toolkit · data as of 2026-11-04

Is Tourfic Toolkit safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.4)

As of 2026-11-04. 3 issues are on record for older versions; version 1.5.2 or newer fixes all of them that state a fix.

Latest version
1.5.4
Last updated
2026-09-23
Active installs
900+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Companion plugin for Travelfic and Ultimate Hotel Booking to build hotel, tour, travel, and accommodation booking websites on WordPress. — by Themefic

What to do

  1. Update to the latest version (1.5.4). Anything older than 1.5.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get travelfic-toolkit --field=version shows what you run; wp plugin update travelfic-toolkit updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.1 CVE-2026-28186 · published 2026-08-13

Missing authorization check in Tourfic Toolkit (1.5.1 and older)

Affected
1.5.1 and older
Fixed in
1.5.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Broken Access Control in Travelfic Toolkit <= 1.5.1 versions.

NVD CVE-2026-28186Patchstack advisory

medium 4.3 CVE-2026-24940 · published 2026-02-03

Missing authorization check in Tourfic Toolkit (1.3.3 and older)

Affected
1.3.3 and older
Fixed in
1.3.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Themefic Travelfic Toolkit travelfic-toolkit allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Travelfic Toolkit: from n/a through <= 1.3.3.

NVD CVE-2026-24940Patchstack advisory

medium 6.5 CVE-2025-39585 · published 2025-04-16

Stored cross-site scripting (XSS) in Tourfic Toolkit (1.2.1 and older)

Affected
1.2.1 and older
Fixed in
1.2.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Themefic Travelfic Toolkit travelfic-toolkit allows Stored XSS.This issue affects Travelfic Toolkit: from n/a through <= 1.2.1.

NVD CVE-2025-39585Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Tourfic Toolkit vulnerability status badge
<a href="https://laskyr.com/plugins/travelfic-toolkit"><img src="https://laskyr.com/plugins/travelfic-toolkit/badge.svg" alt="Tourfic Toolkit vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit