Skip to content
Laskyr

Plugins · travelers-map · data as of 2026-11-04

Is Travelers' Map safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.3.5)

As of 2026-11-04. 2 issues are on record for older versions; version 2.3.3 or newer fixes all of them that state a fix.

Latest version
2.3.5
Last updated
2026-09-18
Active installs
1,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.2.4+

Version 2.3.5 Geolocate your posts and display them on an interactive OpenStreetMap map using a simple shortcode. Customize your markers and map. — by Camille V

What to do

  1. Update to the latest version (2.3.5). Anything older than 2.3.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get travelers-map --field=version shows what you run; wp plugin update travelers-map updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-66098 · published 2025-11-21

Stored cross-site scripting (XSS) in Travelers' Map (2.3.2 and older)

Affected
2.3.2 and older
Fixed in
2.3.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Camille V Travelers' Map travelers-map allows Stored XSS.This issue affects Travelers' Map: from n/a through <= 2.3.2.

NVD CVE-2025-66098Patchstack advisory

medium 6.5 CVE-2024-29909 · published 2024-03-27

Stored cross-site scripting (XSS) in Travelers' Map (2.2.0 and older)

Affected
2.2.0 and older
Fixed in
2.2.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Camille Verrier Travelers' Map allows Stored XSS.This issue affects Travelers' Map: from n/a through 2.2.0.

NVD CVE-2024-29909Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Travelers' Map vulnerability status badge
<a href="https://laskyr.com/plugins/travelers-map"><img src="https://laskyr.com/plugins/travelers-map/badge.svg" alt="Travelers' Map vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit