Skip to content
Laskyr

Plugins · tracking-code-manager · data as of 2026-11-04

Is Tracking Code Manager safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.8.0)

As of 2026-11-04. 7 issues are on record for older versions; version 2.7.0 or newer fixes all of them that state a fix.

Latest version
2.8.0
Last updated
2026-08-20
Active installs
90,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 5.6+

A plugin to manage ALL of your tracking code and conversion pixels. Compatible with Facebook Ads, Google Adwords, WooCommerce, Easy Digital Downloads, … — by Data443 Risk Mitigation, Inc.

What to do

  1. Update to the latest version (2.8.0). Anything older than 2.7.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get tracking-code-manager --field=version shows what you run; wp plugin update tracking-code-manager updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.1 CVE-2026-15180 · published 2026-10-15

Reflected cross-site scripting (XSS) in Tracking Code Manager (2.6.0 and older)

Affected
2.6.0 and older
Fixed in
2.7.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Tracking Code Manager plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via 'TCM_ErrorMessages' POST Parameter in all versions up to, and including, 2.6.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2026-15180Wordfence advisoryCode change (fix)

high 7.1 CVE-2026-28172 · published 2026-08-06

Cross-site request forgery (CSRF) in Tracking Code Manager (2.6.0 and older)

Affected
2.6.0 and older
Fixed in
2.7.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Request Forgery (CSRF) in Tracking Code Manager <= 2.6.0 versions.

NVD CVE-2026-28172Patchstack advisory

medium 4.8 CVE-2024-6335 · published 2025-05-15

Stored cross-site scripting (XSS) in Tracking Code Manager (older than 2.3.0)

Affected
older than 2.3.0
Fixed in
2.3.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Tracking Code Manager WordPress plugin before 2.3.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

NVD CVE-2024-6335WPScan advisory

medium 5.9 CVE-2024-10309 · published 2025-01-30

Cross-site scripting (XSS) in Tracking Code Manager (older than 2.4.0)

Affected
older than 2.4.0
Fixed in
2.4.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Tracking Code Manager WordPress plugin before 2.4.0 does not sanitise and escape some of its metabox settings when outputing them in the page, which could allow users with a role as low as Contributor to perform Cross-Site Scripting attacks.

NVD CVE-2024-10309WPScan advisory

medium 6.4 CVE-2024-8721 · published 2024-12-24

Stored cross-site scripting (XSS) in Tracking Code Manager (2.3.0 and older)

Affected
2.3.0 and older
Fixed in
2.4.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Tracking Code Manager plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the tracking code field in all versions up to, and including, 2.3.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. CVE-2024-10309 is a duplicate of this issue.

NVD CVE-2024-8721Wordfence advisoryWPScan advisoryCode change (fix)

medium 4.3 CVE-2024-31347 · published 2024-06-09

Missing authorization check in Tracking Code Manager (2.1.0 and older)

Affected
2.1.0 and older
Fixed in
2.2.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Data443 Tracking Code Manager.This issue affects Tracking Code Manager: from n/a through 2.1.0.

NVD CVE-2024-31347Patchstack advisory

medium 5.9 CVE-2024-2579 · published 2024-03-21

Cross-site scripting (XSS) in Tracking Code Manager (2.0.16 and older)

Affected
2.0.16 and older
Fixed in
2.1.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Data443 Tracking Code Manager.This issue affects Tracking Code Manager: from n/a through 2.0.16.

NVD CVE-2024-2579Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Tracking Code Manager vulnerability status badge
<a href="https://laskyr.com/plugins/tracking-code-manager"><img src="https://laskyr.com/plugins/tracking-code-manager/badge.svg" alt="Tracking Code Manager vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit