Skip to content
Laskyr

Plugins · track-geolocation-of-users-using-contact-form-7 · data as of 2026-11-04

Is Track Geolocation Of Users Using Contact Form 7 safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.0.3)

As of 2026-11-04. 2 issues are on record for older versions; version 3.0.3 or newer fixes all of them that state a fix.

Latest version
3.0.3
Last updated
2026-10-05
Active installs
800+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Track Geolocation Of Users Using Contact Form 7 allows you to get geolocation information with their form submission. — by ZealousWeb

What to do

  1. Update to the latest version (3.0.3). Anything older than 3.0.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get track-geolocation-of-users-using-contact-form-7 --field=version shows what you run; wp plugin update track-geolocation-of-users-using-contact-form-7 updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-73386 · published 2026-08-19

Information disclosure in Track Geolocation Of Users Using Contact Form 7 (3.0.2 and older)

Affected
3.0.2 and older
Fixed in
3.0.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Sensitive Data Exposure in Track Geolocation Of Users Using Contact Form 7 <= 3.0.2 versions.

NVD CVE-2026-73386Patchstack advisory

medium 4.8 CVE-2023-49188 · published 2023-12-15

Stored cross-site scripting (XSS) in Track Geolocation Of Users Using Contact Form 7 (2.0 and older)

Affected
2.0 and older
Fixed in
2.1
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ZealousWeb Track Geolocation Of Users Using Contact Form 7 allows Stored XSS.This issue affects Track Geolocation Of Users Using Contact Form 7: from n/a through 2.0.

NVD CVE-2023-49188Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Track Geolocation Of Users Using Contact Form 7 vulnerability status badge
<a href="https://laskyr.com/plugins/track-geolocation-of-users-using-contact-form-7"><img src="https://laskyr.com/plugins/track-geolocation-of-users-using-contact-form-7/badge.svg" alt="Track Geolocation Of Users Using Contact Form 7 vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit