Plugins · totalcontest-lite · data as of 2026-11-04
Is Photo Contest safe? Known vulnerabilities and latest version
- Latest version
- 2.9.1
- Last updated
- 2025-09-05
- Active installs
- 200+
- Known issues on record
- 3
- Unpatched in latest
- 1
- Tested up to WP
- 6.8.12 · PHP 5.6+
If you're looking to host a contest or competition on your WordPress website, TotalContest is the perfect plugin for you. — by TotalSuite
What to do
- There is no fixed version yet. If you can live without Photo Contest for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get totalcontest-lite --field=version shows what you run; wp plugin update totalcontest-lite updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.3 affects latest 2.9.1 CVE-2026-0677 · published 2026-03-20
PHP object injection in Photo Contest (2.9.1 and older)
- Affected
- 2.9.1 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
Deserialization of Untrusted Data vulnerability in TotalSuite TotalContest Lite totalcontest-lite allows Object Injection.This issue affects TotalContest Lite: from n/a through <= 2.9.1.
high 7.1 CVE-2025-23782 · published 2025-04-17
Reflected cross-site scripting (XSS) in Photo Contest (2.8.1 and older)
- Affected
- 2.8.1 and older
- Fixed in
- 2.9.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in TotalSuite TotalContest Lite totalcontest-lite allows Reflected XSS.This issue affects TotalContest Lite: from n/a through <= 2.8.1.
medium 6.1 CVE-2024-13822 · published 2025-02-24
Reflected cross-site scripting (XSS) in Photo Contest (2.8.1 and older)
- Affected
- 2.8.1 and older
- Fixed in
- 2.9.0 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Photo Contest | Competition | Video Contest WordPress plugin through 2.8.1 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
Recent activity
- 2025-09-05 — latest release on wordpress.org (2.9.1).
- 2026-03-20 — PHP object injection disclosed (CVE-2026-0677), no fix listed yet.
- 2025-04-17 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-23782), fixed in 2.9.0.
- 2025-02-24 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-13822), fixed in 2.9.0.
Get an email when Photo Contest has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Photo Contest (totalcontest-lite) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by TotalSuite (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · PHP object injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/totalcontest-lite (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/totalcontest-lite"><img src="https://laskyr.com/plugins/totalcontest-lite/badge.svg" alt="Photo Contest vulnerability status"></a>