Plugins · top-table-of-contents · data as of 2026-11-04
Is TOP Table Of Contents safe? Known vulnerabilities and latest version
- Status
- Closed 2026-06-09
- Known issues on record
- 1
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate top-table-of-contents && wp plugin delete top-table-of-contents
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 1 record(s) do not state which versions are affected.
medium 4.3 CVE-2026-25314 · published 2026-02-19
Missing authorization check in TOP Table Of Contents (1.3.31 and older)
- Affected
- 1.3.31 and older
- Fixed in
- 1.4.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in WP Messiah TOP Table Of Contents top-table-of-contents allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects TOP Table Of Contents: from n/a through <= 1.3.31.
Recent activity
- 2026-06-09 — closed on wordpress.org (Guideline Violation).
- 2026-02-19 — Missing authorization check disclosed (CVE-2026-25314), fixed in 1.4.0.
Get an email when TOP Table Of Contents has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for TOP Table Of Contents (top-table-of-contents) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/top-table-of-contents (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/top-table-of-contents"><img src="https://laskyr.com/plugins/top-table-of-contents/badge.svg" alt="TOP Table Of Contents vulnerability status"></a>