Plugins · top-10 · data as of 2026-11-04
Is WebberZone Top 10 safe? Known vulnerabilities and latest version
- Latest version
- 4.6.2
- Last updated
- 2026-11-03
- Active installs
- 10,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Track post views and page views, and display popular posts and trending content on your WordPress site. — by Ajay
What to do
- Update to the latest version (4.6.2). Anything older than 4.5.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get top-10 --field=version shows what you run; wp plugin update top-10 updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-110290 · published 2026-10-16
Stored cross-site scripting (XSS) in WebberZone Top 10 (4.5.2 and older)
- Affected
- 4.5.2 and older
- Fixed in
- 4.5.3 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WebberZone Top 10 — Popular Posts plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'other_attributes (parsed to inject instance_id) + undeclared is_widget' parameter in all versions up to, and including, 4.5.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The exploit requires setting the undeclared is_widget flag to '1' via block JSON, which activates the vulnerable code path that concatenates the attacker-controlled instance_id value into an unescaped HTML class attribute.
NVD CVE-2026-110290Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2025-47509 · published 2025-05-07
Stored cross-site scripting (XSS) in WebberZone Top 10 (4.1.0 and older)
- Affected
- 4.1.0 and older
- Fixed in
- 4.1.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ajay Top 10 top-10 allows Stored XSS.This issue affects Top 10: from n/a through <= 4.1.0.
medium 4.3 CVE-2023-25993 · published 2024-12-09
Missing authorization check in WebberZone Top 10 (3.2.3 and older)
- Affected
- 3.2.3 and older
- Fixed in
- 3.2.4
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in WebberZone Top 10 allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Top 10: from n/a through 3.2.3.
high 8.8 CVE-2023-47238 · published 2023-11-09
Cross-site request forgery (CSRF) in WebberZone Top 10 (3.3.2 and older)
- Affected
- 3.3.2 and older
- Fixed in
- 3.3.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in WebberZone Top 10 – WordPress Popular posts by WebberZone plugin <= 3.3.2 versions.
medium 4.3 CVE-2020-36761 · published 2023-07-12
Cross-site request forgery (CSRF) in WebberZone Top 10 (older than 2.9.5)
- Affected
- older than 2.9.5
- Fixed in
- 2.9.5
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Top 10 plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.10.4. This is due to missing or incorrect nonce validation on the tptn_export_tables() function. This makes it possible for unauthenticated attackers to generate an export of the top 10 table via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2020-36761Wordfence advisoryCode change (fix)blog.nintechnet.comblog.nintechnet.comblog.nintechnet.comblog.nintechnet.com
medium 4.8 CVE-2023-26008 · published 2023-03-23
Stored cross-site scripting (XSS) in WebberZone Top 10 (3.2.4 and older)
- Affected
- 3.2.4 and older
- Fixed in
- 3.2.5
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Ajay D'Souza Top 10 – Popular posts plugin for WordPress plugin <= 3.2.4 versions.
Recent activity
- 2026-11-03 — latest release on wordpress.org (4.6.2).
- 2026-10-16 — Stored cross-site scripting (XSS) disclosed (CVE-2026-110290), fixed in 4.5.3.
- 2025-05-07 — Stored cross-site scripting (XSS) disclosed (CVE-2025-47509), fixed in 4.1.1.
- 2024-12-09 — Missing authorization check disclosed (CVE-2023-25993), fixed in 3.2.4.
Get an email when WebberZone Top 10 has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WebberZone Top 10 (top-10) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Ajay (4 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3) · Cross-site request forgery (CSRF) (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/top-10 (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/top-10"><img src="https://laskyr.com/plugins/top-10/badge.svg" alt="WebberZone Top 10 vulnerability status"></a>