Skip to content
Laskyr

Plugins · toocheke-companion · data as of 2026-11-04

Is Toocheke Companion safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.38)

As of 2026-11-04. 3 issues are on record for older versions; version 2.11 or newer fixes all of them that state a fix.

Latest version
2.38
Last updated
2026-11-01
Active installs
1,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4

Transform your WordPress theme into a platform for publishing your webcomics. — by Leetoo

What to do

  1. Update to the latest version (2.38). Anything older than 2.11 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get toocheke-companion --field=version shows what you run; wp plugin update toocheke-companion updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-15604 · published 2026-08-16

Stored cross-site scripting (XSS) in Toocheke Companion (2.10 and older)

Affected
2.10 and older
Fixed in
2.11 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Toocheke Companion plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 2.10 via the 'series_bg_color' post meta field. This is due to insufficient input sanitization in the toocheke_series_bg_color_save() function (which stores the raw $_POST value in post meta) and insufficient output escaping in the series admin column rendering (where the stored value is concatenated into a style attribute without esc_attr()). This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user, such as an administrator, accesses the series list table in the admin dashboard.

NVD CVE-2026-15604Wordfence advisoryPlugin source

medium 6.5 CVE-2026-32403 · published 2026-03-13

Cross-site scripting (XSS) in Toocheke Companion (1.194 and older)

Affected
1.194 and older
Fixed in
1.195
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in toocheke Toocheke Companion toocheke-companion allows DOM-Based XSS.This issue affects Toocheke Companion: from n/a through <= 1.194.

NVD CVE-2026-32403Patchstack advisory

medium 5.9 CVE-2025-23992 · published 2025-01-22

Stored cross-site scripting (XSS) in Toocheke Companion (1.166 and older)

Affected
1.166 and older
Fixed in
1.167
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in toocheke Toocheke Companion toocheke-companion allows Stored XSS.This issue affects Toocheke Companion: from n/a through <= 1.166.

NVD CVE-2025-23992Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Toocheke Companion vulnerability status badge
<a href="https://laskyr.com/plugins/toocheke-companion"><img src="https://laskyr.com/plugins/toocheke-companion/badge.svg" alt="Toocheke Companion vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit