Plugins · token-of-trust · data as of 2026-11-04
Is Age Verification & Identity Verification by To… safe? Known vulnerabilities and latest version
- Latest version
- 4.4.0
- Last updated
- 2026-10-30
- Active installs
- 30+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.2.5+
Verify customer age and identity using government-issued ID. Works at WooCommerce checkout, on selected products, or on any WordPress page. — by Token of Trust
What to do
- Update to the latest version (4.4.0). Anything older than 4.0.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get token-of-trust --field=version shows what you run; wp plugin update token-of-trust updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-7558 · published 2026-07-09
Missing authorization check in Age Verification & Identity Verification by To… (4.0.2 and older)
- Affected
- 4.0.2 and older
- Fixed in
- 4.0.3 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Age Verification & Identity Verification by Token of Trust plugin for WordPress is vulnerable to unauthorized access in all versions up to and including 4.0.2. This is due to the handle_export_table() function being registered on the WordPress 'init' hook, which fires for all requests, including those from unauthenticated visitors, without any capability check. This makes it possible for unauthenticated attackers to download a CSV file containing sensitive WooCommerce donation data, including order dates, order IDs, charitable donation amounts, and admin-only order edit URLs, simply by visiting any page on the site with the 'tot_export_table' GET parameter set to a numeric value (0–3).
NVD CVE-2026-7558Wordfence advisoryCode change (fix)Plugin source
high 7.2 CVE-2026-2834 · published 2026-04-15
Stored cross-site scripting (XSS) in Age Verification & Identity Verification by To… (3.32.3 and older)
- Affected
- 3.32.3 and older
- Fixed in
- 3.32.4 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Age Verification & Identity Verification by Token of Trust plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘description’ parameter in all versions up to, and including, 3.32.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recent activity
- 2026-10-30 — latest release on wordpress.org (4.4.0).
- 2026-07-09 — Missing authorization check disclosed (CVE-2026-7558), fixed in 4.0.3.
- 2026-04-15 — Stored cross-site scripting (XSS) disclosed (CVE-2026-2834), fixed in 3.32.4.
Get an email when Age Verification & Identity Verification by To… has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Age Verification & Identity Verification by To… (token-of-trust) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/token-of-trust (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/token-of-trust"><img src="https://laskyr.com/plugins/token-of-trust/badge.svg" alt="Age Verification & Identity Verification by To… vulnerability status"></a>