Skip to content
Laskyr

Plugins · tnc-toolbox · data as of 2026-11-04

Is TNC Toolbox safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1.4)

As of 2026-11-04. 2 issues are on record for older versions; version 2.0.5 or newer fixes all of them that state a fix.

Latest version
2.1.4
Last updated
2026-03-27
Active installs
1,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11

Multi-stack caching for WordPress: ea-NGINX (cPanel) and LiteSpeed (OpenLS/Enterprise). Auto-detects web server! — by Merlot Digital (by TNC)

What to do

  1. Update to the latest version (2.1.4). Anything older than 2.0.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get tnc-toolbox --field=version shows what you run; wp plugin update tnc-toolbox updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-66108 · published 2025-11-21

Missing authorization check in TNC Toolbox (2.0.4 and older)

Affected
2.0.4 and older
Fixed in
2.0.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Merlot Digital (by TNC) TNC Toolbox: Web Performance tnc-toolbox allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects TNC Toolbox: Web Performance: from n/a through <= 2.0.4.

NVD CVE-2025-66108Patchstack advisory

critical 10.0 CVE-2025-12539 · published 2025-11-11

Arbitrary file upload in TNC Toolbox (1.4.2 and older)

Affected
1.4.2 and older
Fixed in
2.0.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The TNC Toolbox: Web Performance plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.4.2. This is due to the plugin storing cPanel API credentials (hostname, username, and API key) in files within the web-accessible wp-content directory without adequate protection in the "Tnc_Wp_Toolbox_Settings::save_settings" function. This makes it possible for unauthenticated attackers to retrieve these credentials and use them to interact with the cPanel API, which can lead to arbitrary file uploads, remote code execution, and full compromise of the hosting environment.

NVD CVE-2025-12539Wordfence advisorygithub.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
TNC Toolbox vulnerability status badge
<a href="https://laskyr.com/plugins/tnc-toolbox"><img src="https://laskyr.com/plugins/tnc-toolbox/badge.svg" alt="TNC Toolbox vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit