Plugins · timeslot · data as of 2026-11-04
Is Time Slot safe? Known vulnerabilities and latest version
- Latest version
- 1.6.2
- Last updated
- 2026-11-03
- Active installs
- 100+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.1+
Book appointments online with a simple booking form and flexible scheduling. Time Slot is a lightweight booking plugin with a powerful booking system. — by Time Slot Booking
What to do
- Update to the latest version (1.6.2). Anything older than 1.4.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get timeslot --field=version shows what you run; wp plugin update timeslot updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2025-12842 · published 2025-11-19
Security issue in Time Slot (1.4.7 and older)
- Affected
- 1.4.7 and older
- Fixed in
- 1.4.8 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Booking Plugin for WordPress Appointments – Time Slot plugin for WordPress is vulnerable to unauthorized email sending in versions up to, and including, 1.4.7 due to missing validation on the tslot_appt_email AJAX action. This makes it possible for unauthenticated attackers to send appointment notification emails to arbitrary recipients with attacker-controlled text content in certain email fields, potentially enabling the site to be abused for phishing campaigns or spam distribution.
NVD CVE-2025-12842Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2024-50418 · published 2024-10-29
Cross-site scripting (XSS) in Time Slot (1.3.6 and older)
- Affected
- 1.3.6 and older
- Fixed in
- 1.3.7
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Time Slot Booking Time Slot timeslot allows DOM-Based XSS.This issue affects Time Slot: from n/a through <= 1.3.6.
Recent activity
- 2026-11-03 — latest release on wordpress.org (1.6.2).
- 2025-11-19 — Security issue disclosed (CVE-2025-12842), fixed in 1.4.8.
- 2024-10-29 — Cross-site scripting (XSS) disclosed (CVE-2024-50418), fixed in 1.3.7.
Get an email when Time Slot has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Time Slot (timeslot) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/timeslot (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/timeslot"><img src="https://laskyr.com/plugins/timeslot/badge.svg" alt="Time Slot vulnerability status"></a>