Skip to content
Laskyr

Plugins · timeline-block-block · data as of 2026-11-04

Is Timeline Block safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.7)

As of 2026-11-04. 2 issues are on record for older versions; version 1.3.4 or newer fixes all of them that state a fix.

Latest version
1.5.7
Last updated
2026-10-29
Active installs
3,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Create beautiful horizontal and vertical timelines in Gutenberg. Customizable themes to showcase stories, events, projects, and milestones. — by bPlugins

What to do

  1. Update to the latest version (1.5.7). Anything older than 1.3.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get timeline-block-block --field=version shows what you run; wp plugin update timeline-block-block updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-1228 · published 2026-02-06

Missing authorization check in Timeline Block (1.3.3 and older)

Affected
1.3.3 and older
Fixed in
1.3.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Timeline Block – Beautiful Timeline Builder for WordPress (Vertical & Horizontal Timelines) plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 1.3.3 via the tlgb_shortcode() function due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with Author-level access and above, to disclose private timeline content via the id attribute supplied to the 'timeline_block' shortcode.

NVD CVE-2026-1228Wordfence advisoryCode change (fix)

medium 6.5 CVE-2025-26754 · published 2025-02-17

Stored cross-site scripting (XSS) in Timeline Block (1.1.1 and older)

Affected
1.1.1 and older
Fixed in
1.1.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Timeline Block timeline-block-block allows Stored XSS.This issue affects Timeline Block: from n/a through <= 1.1.1.

NVD CVE-2025-26754Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Timeline Block vulnerability status badge
<a href="https://laskyr.com/plugins/timeline-block-block"><img src="https://laskyr.com/plugins/timeline-block-block/badge.svg" alt="Timeline Block vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit