Plugins · tier-management-petfinder · data as of 2026-11-04
Is Pet-Manager safe? Known vulnerabilities and latest version
- Latest version
- 3.6.3
- Last updated
- 2025-11-17
- Active installs
- 40+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 6.5.14 · PHP 7.0+
Verbinden Sie ihre Website mit der Pet-Manager-Software von KW-Management — by kwmanagement
What to do
- Update to the latest version (3.6.3). Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get tier-management-petfinder --field=version shows what you run; wp plugin update tier-management-petfinder updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2025-12710 · published 2025-11-19
Stored cross-site scripting (XSS) in Pet-Manager (3.6.1 and older)
- Affected
- 3.6.1 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Pet-Manager – Petfinder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the kwm-petfinder shortcode in all versions up to, and including, 3.6.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2025-12710Wordfence advisoryCode change (fix)Plugin source
medium 4.8 CVE-2024-3918 · published 2024-05-23
Stored cross-site scripting (XSS) in Pet-Manager (1.4 and older)
- Affected
- 1.4 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Pet Manager WordPress plugin through 1.4 does not sanitise and escape some of its Pet settings, which could allow high privilege users such as Contributor to perform Stored Cross-Site Scripting attacks.
medium 6.1 CVE-2024-3917 · published 2024-05-23
Reflected cross-site scripting (XSS) in Pet-Manager (1.4 and older)
- Affected
- 1.4 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Pet Manager WordPress plugin through 1.4 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Recent activity
- 2025-11-17 — latest release on wordpress.org (3.6.3).
- 2025-11-19 — Stored cross-site scripting (XSS) disclosed (CVE-2025-12710), fix version not stated.
- 2024-05-23 — Stored cross-site scripting (XSS) disclosed (CVE-2024-3918), fix version not stated.
- 2024-05-23 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-3917), fix version not stated.
Get an email when Pet-Manager has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Pet-Manager (tier-management-petfinder) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/tier-management-petfinder (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/tier-management-petfinder"><img src="https://laskyr.com/plugins/tier-management-petfinder/badge.svg" alt="Pet-Manager vulnerability status"></a>