Plugins · thrivedesk · data as of 2026-11-04
Is ThriveDesk safe? Known vulnerabilities and latest version
- Latest version
- 2.7.1
- Last updated
- 2026-09-07
- Active installs
- 100+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Help desk, live chat and AI chatbot for WordPress and WooCommerce. Every email, chat and support ticket in one shared inbox, with orders inside. — by ThriveDesk
What to do
- Update to the latest version (2.7.1). Anything older than 2.2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get thrivedesk --field=version shows what you run; wp plugin update thrivedesk updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-1832 · published 2026-07-11
Missing authorization check in ThriveDesk (2.1.7 and older)
- Affected
- 2.1.7 and older
- Fixed in
- 2.2.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The ThriveDesk – Live Chat, AI Chatbot, Helpdesk & Knowledge Base plugin for WordPress is vulnerable to unauthorized cache deletion due to a missing capability check on the 'thrivedesk_clear_cache' AJAX action in all versions up to, and including, 2.1.7. This makes it possible for authenticated attackers, with Subscriber-level access and above, to clear the plugin's cache.
NVD CVE-2026-1832Wordfence advisoryCode change (fix)cwe.mitre.orgPlugin source
high 7.1 CVE-2025-24536 · published 2025-02-03
Reflected cross-site scripting (XSS) in ThriveDesk (2.0.6 and older)
- Affected
- 2.0.6 and older
- Fixed in
- 2.0.7
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ThriveDesk ThriveDesk thrivedesk allows Reflected XSS.This issue affects ThriveDesk: from n/a through <= 2.0.6.
Recent activity
- 2026-09-07 — latest release on wordpress.org (2.7.1).
- 2026-07-11 — Missing authorization check disclosed (CVE-2026-1832), fixed in 2.2.0.
- 2025-02-03 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-24536), fixed in 2.0.7.
Get an email when ThriveDesk has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for ThriveDesk (thrivedesk) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/thrivedesk (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/thrivedesk"><img src="https://laskyr.com/plugins/thrivedesk/badge.svg" alt="ThriveDesk vulnerability status"></a>