Plugins · thirstyaffiliates · data as of 2026-11-04
Is ThirstyAffiliates safe? Known vulnerabilities and latest version
- Latest version
- 3.12.2
- Last updated
- 2026-10-29
- Active installs
- 30,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
🔗 Affiliate link management & cloaker tool. Easily manage, shrink and track your affiliate links in WordPress. 🔥 — by Blair Williams
What to do
- Update to the latest version (3.12.2). Anything older than 3.12.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get thirstyaffiliates --field=version shows what you run; wp plugin update thirstyaffiliates updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-119089 · published 2026-10-31
Stored cross-site scripting (XSS) in ThirstyAffiliates (3.12.1 and older)
- Affected
- 3.12.1 and older
- Fixed in
- 3.12.2 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The ThirstyAffiliates – Affiliate Links, Link Branding, Link Tracking & Marketing Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 3.12.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is only exploitable on block themes (such as Twenty Twenty-Five) where the Comment Content block causes comment HTML to flow through render_block, triggering the plugin's transformer. Additionally, a successful attack requires the attacker to have had one prior comment approved, after which subsequent crafted comments are auto-approved and rendered publicly.
NVD CVE-2026-119089Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2026-97314 · published 2026-10-17
Information disclosure in ThirstyAffiliates (older than 3.12.1)
- Affected
- older than 3.12.1
- Fixed in
- 3.12.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The ThirstyAffiliates WordPress plugin before 3.12.1 does not check the status or type of the object requested by its link redirect tracking handler, allowing unauthenticated attackers to disclose the destination URLs of unpublished affiliate links and to record fabricated click statistics.
medium 5.4 CVE-2026-25024 · published 2026-02-03
Cross-site request forgery (CSRF) in ThirstyAffiliates (3.11.9 and older)
- Affected
- 3.11.9 and older
- Fixed in
- 3.11.10
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Blair Williams ThirstyAffiliates thirstyaffiliates allows Cross Site Request Forgery.This issue affects ThirstyAffiliates: from n/a through <= 3.11.9.
medium 6.5 CVE-2025-67537 · published 2025-12-09
Stored cross-site scripting (XSS) in ThirstyAffiliates (3.11.8 and older)
- Affected
- 3.11.8 and older
- Fixed in
- 3.11.9
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Blair Williams ThirstyAffiliates thirstyaffiliates allows Stored XSS.This issue affects ThirstyAffiliates: from n/a through <= 3.11.8.
medium 4.3 CVE-2022-0634 · published 2022-04-25
Cross-site request forgery (CSRF) in ThirstyAffiliates (older than 3.10.5)
- Affected
- older than 3.10.5
- Fixed in
- 3.10.5
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The ThirstyAffiliates WordPress plugin before 3.10.5 lacks authorization checks in the ta_insert_external_image action, allowing a low-privilege user (with a role as low as Subscriber) to add an image from an external URL to an affiliate link. Further the plugin lacks csrf checks, allowing an attacker to trick a logged in user to perform the action by crafting a special request.
medium 5.4 CVE-2021-24127 · published 2021-03-18
Stored cross-site scripting (XSS) in ThirstyAffiliates (older than 3.9.3)
- Affected
- older than 3.9.3
- Fixed in
- 3.9.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
Unvalidated input and lack of output encoding in the ThirstyAffiliates Affiliate Link Manager WordPress plugin, versions before 3.9.3, was vulnerable to authenticated Stored Cross-Site Scripting (XSS), which could lead to privilege escalation.
Recent activity
- 2026-10-29 — latest release on wordpress.org (3.12.2).
- 2026-10-31 — Stored cross-site scripting (XSS) disclosed (CVE-2026-119089), fixed in 3.12.2.
- 2026-10-17 — Information disclosure disclosed (CVE-2026-97314), fixed in 3.12.1.
- 2026-02-03 — Cross-site request forgery (CSRF) disclosed (CVE-2026-25024), fixed in 3.11.10.
Get an email when ThirstyAffiliates has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for ThirstyAffiliates (thirstyaffiliates) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Blair Williams (3 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3) · Cross-site request forgery (CSRF) (2) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/thirstyaffiliates (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/thirstyaffiliates"><img src="https://laskyr.com/plugins/thirstyaffiliates/badge.svg" alt="ThirstyAffiliates vulnerability status"></a>