Plugins · thim-elementor-kit · data as of 2026-11-04
Is Thim Kit for Elementor safe? Known vulnerabilities and latest version
- Latest version
- 1.4.8
- Last updated
- 2026-10-13
- Active installs
- 20,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
Thim Elementor Kit is a plugin which supports users to build theme, layout, page, post, product, Woocommerce, LearnPress, courses with Elementor. — by ThimPress
What to do
- Update to the latest version (1.4.8). Anything older than 1.3.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get thim-elementor-kit --field=version shows what you run; wp plugin update thim-elementor-kit updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-1870 · published 2026-03-16
Missing authorization check in Thim Kit for Elementor (1.3.7 and older)
- Affected
- 1.3.7 and older
- Fixed in
- 1.3.8 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Thim Kit for Elementor – Pre-built Templates & Widgets for Elementor plugin for WordPress is vulnerable to unauthorized access of data due to a missing validation checks on the 'thim-ekit/archive-course/get-courses' REST endpoint callback function in all versions up to, and including, 1.3.7. This makes it possible for unauthenticated attackers to disclose private or draft LearnPress course content by supplying post_status in the params_url payload.
medium 4.3 CVE-2025-67594 · published 2025-12-09
Missing authorization check in Thim Kit for Elementor (1.3.3 and older)
- Affected
- 1.3.3 and older
- Fixed in
- 1.3.4
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Authorization Bypass Through User-Controlled Key vulnerability in ThimPress Thim Elementor Kit thim-elementor-kit allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Thim Elementor Kit: from n/a through <= 1.3.3.
medium 4.3 CVE-2025-24725 · published 2025-01-24
Missing authorization check in Thim Kit for Elementor (1.2.8 and older)
- Affected
- 1.2.8 and older
- Fixed in
- 1.2.9
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in ThimPress Thim Elementor Kit thim-elementor-kit allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Thim Elementor Kit: from n/a through <= 1.2.8.
medium 6.5 CVE-2025-22312 · published 2025-01-07
Cross-site scripting (XSS) in Thim Kit for Elementor (1.2.9 and older)
- Affected
- 1.2.9 and older
- Fixed in
- 1.2.9.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ThimPress Thim Elementor Kit thim-elementor-kit allows DOM-Based XSS.This issue affects Thim Elementor Kit: from n/a through <= 1.2.9.
medium 6.4 CVE-2024-4329 · published 2024-05-14
Stored cross-site scripting (XSS) in Thim Kit for Elementor (1.1.9 and older)
- Affected
- 1.1.9 and older
- Fixed in
- 1.1.9.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Thim Elementor Kit plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘id’ parameter in all versions up to, and including, 1.1.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
medium 6.5 CVE-2024-34415 · published 2024-05-14
Stored cross-site scripting (XSS) in Thim Kit for Elementor (1.1.8 and older)
- Affected
- 1.1.8 and older
- Fixed in
- 1.1.9
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ThimPress Thim Elementor Kit allows Stored XSS.This issue affects Thim Elementor Kit: from n/a through 1.1.8.
Recent activity
- 2026-10-13 — latest release on wordpress.org (1.4.8).
- 2026-03-16 — Missing authorization check disclosed (CVE-2026-1870), fixed in 1.3.8.
- 2025-12-09 — Missing authorization check disclosed (CVE-2025-67594), fixed in 1.3.4.
- 2025-01-24 — Missing authorization check disclosed (CVE-2025-24725), fixed in 1.2.9.
Get an email when Thim Kit for Elementor has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Thim Kit for Elementor (thim-elementor-kit) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by ThimPress (9 tracked)
Types found in this plugin: Missing authorization (3) · Cross-site scripting (XSS) (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/thim-elementor-kit (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/thim-elementor-kit"><img src="https://laskyr.com/plugins/thim-elementor-kit/badge.svg" alt="Thim Kit for Elementor vulnerability status"></a>